POJ 3687 Labeling Balls

题目链接 : POJ3687

Labeling Balls

Time Limit: 1000MS

 Memory Limit: 65536K
Total Submissions: 8714 Accepted: 2366

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 toN in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled withb".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers,N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The nextM line each contain two integers a and b indicating the ball labeled witha must be lighter than the one labeled with b. (1 ≤ a, bN) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to labelN. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

以后补~

 

 

#include <cstdio>
#include <algorithm>
#include <string.h>
using namespace std;
const int N = 205, M = 40005;
int map[N][N] = {0}, in[N] = {0}, ans[N];
int main()
{
    int t, n, m, a, b, i, j, k;
    scanf("%d", &t);
    while (t--) {
        memset(map,0,sizeof(map));
        memset(in,0,sizeof(in)) ;
        scanf("%d%d", &n, &m);
        for (i = 0; i < m; ++i) {
            scanf("%d%d", &a, &b);
            if (!map[b][a]) {
               map[b][a] = 1;
               ++in[a];
            }
        }
        for (i = n; i >= 1 ; i--) {
            for (j = n ; j >=1 && in[j]; j--) {
                if (in[j] < 0) continue;
            }
            if (j < 1) break;
            ans[j] = i ;
            in[j] = -1;
            for (k = 1; k <= n; ++k)
                if (map[j][k]) --in[k];
        }
        if (i >= 1) printf("-1\n");
        else {
            printf("%d", ans[1]);
            for (i = 2; i <= n; ++i) printf(" %d", ans[i]);
            putchar('\n');
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值