POJ 2318 计算几何+二分

TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10425 Accepted: 5002
Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.
Source

Rocky Mountain 2003

/***********************************************
     author     : Grant Yuan
     time       : 2014/8/18 17:12
     algorithm  : 计算几何+二分
     source     : POJ 2318
************************************************/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define MAX 5007

using namespace std;

int n,m,x1,y1,x2,y2;
int ans[MAX];
int left,right,l,r,mid,res;

struct Point
{
    int x,y;
    Point() {};
    Point(int _x,int _y){x=_x;y=_y;}
    Point operator -(const Point &b)
    {
        return Point(x-b.x,y-b.y);
    }
    int operator *(const Point &b)
    {
        return x*b.x+y*b.y;
    }
    int operator ^(const Point &b)
    {
        return x*b.y-y*b.x;
    }
};

struct Line
{
    Point a,b;
    Line(){};
    Line(Point _a,Point _b){a=_a;b=_b;}
};
Line line[MAX];

int xmult(Point p0,Point p1,Point p2)
{
    return(p1-p0)^(p2-p0);
}

int main()
{
    int x3,y3;
    Point p1,p2,p;Line l1;
    bool first=true;
    while(~scanf("%d",&n)&&n){
        if(!first) printf("\n");
        if(first) first=false;
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        memset(ans,0,sizeof(ans));
        memset(line,0,sizeof(line));
        int Ui,Li;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&Ui,&Li);
            line[i]=Line(Point(Ui,y1),Point(Li,y2));
        }
            line[n]=Line(Point(x2,y1),Point(x2,y2));
        while(m--)
        {
            scanf("%d%d",&x3,&y3);
            p=Point(x3,y3);
            l=0;r=n;
            while(l<=r)
            {
                mid=(l+r)>>1;
                if(xmult(p,line[mid].a,line[mid].b)<0){
                    r=mid-1;
                    res=mid;
                }
                else l=mid+1;
            }
            ans[res]++;
        }
        for(int i=0;i<=n;i++)
        {
            printf("%d: %d\n",i,ans[i]);
        }

    }
    return 0;
}


 

转载于:https://www.cnblogs.com/codeyuan/p/4254455.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值