poj 2941 Homogeneous Squares

Homogeneous Squares
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 3344 Accepted: 1808

Description

Assume you have a square of size n that is divided into n × n positions just as a checkerboard. Two positions (x1, y1) and (x2, y2), where 1 ≤ x1, y1, x2, y2n, are called “independent” if they occupy different rows and different columns, that is, x1x2 and y1y2. More generally, n positions are called independent if they are pairwise independent. It follows that there are n! different ways to choose n independent positions.

Assume further that a number is written in each position of such an n × n square. This square is called “homogeneous” if the sum of the numbers written in n independent positions is the same, no matter how the positions are chosen. Write a program to determine if a given square is homogeneous!

Input

The input contains several test cases.

The first line of each test case contains an integer n (1 ≤ n ≤ 1000). Each of the next n lines contains n numbers, separated by exactly one space character. Each number is an integer from the interval [−1000000, 1000000].

The last test case is followed by a zero.

Output

For each test case output whether the specified square is homogeneous or not. Adhere to the format shown in the sample output.

Sample Input

2
1 2
3 4
3
1 3 4
8 6 -2
-3 4 0
0

Sample Output

homogeneous
not homogeneous
#include <iostream>
using namespace std;

int a[1001][1001];

int main()
{
int i,j,k,n;
while(scanf("%d",&n) && n!=0)
{
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&a[i][j]);
int flag=0;
for(i=1;i<n && !flag;i++)
{
if(flag==1)
break;
for(j=0;j<i && !flag;j++)
{
if(flag==1)
break;
for(k=0;k<i && !flag;k++)
{
if(a[i][i]+a[j][k] != a[i][k]+a[j][i])
{
flag=1;
break;
}
}
}
}
if(flag==1)
printf("not homogeneous\n");
else
printf("homogeneous\n");
}
return 1;
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/22/2258741.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值