poj 2941 Homogeneous Squares 解题报告

题目:

Homogeneous Squares
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 4721 Accepted: 2393

Description

Assume you have a square of size n that is divided into n × n positions just as a checkerboard. Two positions (x1y1) and (x2y2), where 1 ≤ x1y1x2y2 ≤ n, are called “independent” if they occupy different rows and different columns, that is, x1 ≠ x2 and y1 ≠y2. More generally, n positions are called independent if they are pairwise independent. It follows that there are n! different ways to choose n independent positions.

Assume further that a number is written in each position of such an n × n square. This square is called “homogeneous” if the sum of the numbers written in n independent positions is the same, no matter how the positions are chosen. Write a program to determine if a given square is homogeneous!

Input

The input contains several test cases.

The first line of each test case contains an integer n (1 ≤ n ≤ 1000). Each of the next n lines contains n numbers, separated by exactly one space character. Each number is an integer from the interval [−1000000, 1000000].

The last test case is followed by a zero.

Output

For each test case output whether the specified square is homogeneous or not. Adhere to the format shown in the sample output.

Sample Input

2
1 2
3 4
3
1 3 4
8 6 -2
-3 4 0
0

Sample Output

homogeneous
not homogeneous



每组数据给定一个n*n的矩阵,选定不同行不同列的n个元素求和,看所有选法所产生的和是否相等。


分析:

分析发现,对于一个n阶矩阵,只要它所有n-1阶子矩阵符合要求即可,递归得,只要它所有2阶子矩阵符合两对角线相乘相等即可。


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <limits.h>
using namespace std;

int n,a[1009][1009];

int main(){
    while(~scanf("%d",&n),n){
    	for(int i=0;i<n;++i){
    		for(int j=0;j<n;++j){
    			scanf("%d",&a[i][j]);
    		}
    	}
    	int flag=1;
    	for(int i=0;i<n-1;++i){
    		for(int j=0;j<n-1;++j){
    			if((a[i][j]+a[i+1][j+1])!=(a[i+1][j]+a[i][j+1])){
    				flag=0;
    				break;
    			}
    		}
    		if(!flag) break;
    	}
    	if(!flag) puts("not homogeneous");
    	else puts("homogeneous");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值