POJ 3356 AGTC

AGTC
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8101 Accepted: 3212

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

 

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

 

Certainly, we would like to minimize the number of all possible operations.

Illustration

 

A G T A A G T * A G G C

| | | | | | |
A G T * C * T G A C G C

 

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

 

A  G  T  A  A  G  T  A  G  G  C

| | | | | | |
A G T C T G * A C G C

 

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4
题目大意:给定两个字符串,两个字符串的字母可以进行插入,删除,或者替换操作,问最少进行多少次操作可以使两个字符串相等。
解题方法:类似于最长公共子序列,有两种方法可以解答。第一种直接求两个字符串的最长公共子序列,然后用较长字符串的长度减去最长公共子序列的长度,第二种方法是直接求最少需要的操作。
方法一:
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

int dp[1005][1005];


int main()
{
    char str1[1005];
    char str2[1005];
    int n1, n2;
    int MaxLen;
    while(cin>>n1>>str1>>n2>>str2)
    {
        memset(dp, 0, sizeof(dp));
        MaxLen = n1 > n2 ? n1 : n2;
        for (int i = 1; i <= n1; i++)
        {
            for (int j = 1; j <= n2; j++)
            {
                if (str1[i - 1] == str2[j - 1])
                {
                    dp[i][j] = dp[i - 1][j - 1] + 1;
                }
                else
                {
                    dp[i][j] = dp[i - 1][j] > dp[i][j - 1] ? dp[i - 1][j] : dp[i][j - 1];
                }
            }
        }
        printf("%d\n", MaxLen - dp[n1][n2]);
    }
    return 0;
}

方法二:

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

int dp[1005][1005];

int Min(int a, int b, int c)
{
    a = a > b ? b : a;
    a = a > c ? c : a;
    return a;
}


int main()
{
    char str1[1005];
    char str2[1005];
    int n1, n2;
    while(cin>>n1>>str1>>n2>>str2)
    {
        for (int i = 0; i <= n1; i++)
        {
            dp[i][0] = i;
        }
        for (int i = 0; i <= n2; i++)
        {
            dp[0][i] = i;
        }
        for (int i = 1; i <= n1; i++)
        {
            for (int j = 1; j <= n2; j++)
            {
                if (str1[i - 1] == str2[j - 1])
                {
                    dp[i][j] = Min(dp[i - 1][j - 1], dp[i - 1][j] + 1, dp[i][j - 1] + 1);
                }
                else
                {
                    dp[i][j] = Min(dp[i - 1][j], dp[i][j - 1], dp[i - 1][j - 1]) + 1;
                }
            }
        }
        printf("%d\n", dp[n1][n2]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/lzmfywz/p/3180480.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值