Heavy Transportation(POJ - 1797 变形版 dijkstra)

Background

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand

business. But he needs a clever man who tells him whether there really is a way from the place

his customer has build his giant steel crane to the place where it is needed on which all

streets can carry the weight.

Fortunately he already has a plan of the city with all streets and bridges and all the allowed

weights.Unfortunately he has no idea how to find the the maximum weight capacity in order

to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the

crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can

be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may

assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of

street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The

following m lines contain triples of integers specifying start and end crossing of the street and

the maximum allowed weight, which is positive and not larger than 1000000. There will be at

most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the

number of the scenario starting at 1. Then print a single line containing the maximum allowed

weight that Hugo can transport to the customer. Terminate the output for the scenario with a

blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

//注意题上最后让输出2个换行
//#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std;

const int INF=1e9+7;
const int maxn=1100;
typedef long long ll;

int t,n,m;
int vis[maxn];
int par[maxn];
int tu[maxn][maxn];

int dijkstra()
{
    int i,j,k;
    memset(vis,0,sizeof(vis));
    for(i=1; i<=n; i++)
        par[i]=tu[1][i];
    for(i=1; i<=n; i++)
    {
        int minn=-1;
        for(j=1; j<=n; j++)
        {
            if(!vis[j]&&minn<par[j])
            {
                k=j;
                minn=par[j];
            }
        }
        vis[k]=1;
        for(j=1; j<=n; j++)
        {
            par[j]=max(par[j],min(tu[k][j],par[k]));
//            if(!vis[j]&&par[j]<min(tu[k][j],par[k]))
//            {
//                par[j]=min(tu[k][j],par[k]);
//            }
        }
    }
    return par[n];
}

int main()
{
    int cot=1;
    scanf("%d",&t);
    while(t--)
    {
        int i,j,a,b,c;
        scanf("%d %d",&n,&m);
        memset(tu,0,sizeof(tu));
        while(m--)
        {
            scanf("%d %d %d",&a,&b,&c);
            tu[a][b]=tu[b][a]=c;
        }
        printf("Scenario #%d:\n",cot++);
        printf("%d\n\n",dijkstra());
    }
    return 0;
}

转载于:https://www.cnblogs.com/nyist-xsk/p/7264838.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值