Heavy Transportation (POJ—1797)

Heavy Transportation (POJ—1797)

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题目翻译:

背景

雨果·Heavy很高兴。Cargolifter项目失败后,他现在可以扩展业务了。但他需要一个聪明的人,告诉他是否真的有办法从他的客户建造他的巨型钢起重机的地方到所有街道都能承载重量的地方。

幸运的是,他已经有了一个城市规划,包括所有的街道、桥梁和所有允许的重量。不幸的是,他不知道如何找到最大的重量容量,以便告诉他的客户起重机可能变得多么沉重。但你肯定知道。

问题

您得到了城市的平面图,由十字路口之间的街道(带有重量限制)来描述,十字路口的编号从1到n。您的任务是找到从1号交叉口(Hugo's place)到n号交叉口(customer's place)可以运输的最大重量。您可以假设至少有一条路径。所有的街道都可以双向通行。

输入

第一行包含场景(城市规划)的数量。第一行给出了每个城市的十字路口数量n (1 <= n <= 1000)和街道数量m。以下m行包含三组整数,它们指定街道的起点和终点交叉口,以及允许的最大重量,该重量为正,且不大于1000000。每对十字路口之间最多有一条街。

输出

每个场景的输出都以包含“场景#i:”的行开始,其中i是场景的编号,从1开始。然后打印一行包含Hugo可以传输给客户的最大允许重量。用空行结束场景的输出。

思路:

这道题目要求的是从1到N各个路径最小值的最大值,即d[y]=max(d[y],min(d[x],m[x][y]))。

AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <math.h>
#define inf 0x3f3f3f3f
#define MAX 1010
using namespace std;
int t,n,m,sum=0;
int dp[MAX][MAX];
int vis[MAX],dis[MAX];
void dy()
{
    memset(vis,0,sizeof(vis));
    for(int i=1; i<=n; i++)
        dis[i]=dp[1][i];
    dis[1]=0;
    vis[0]=1;
    for(int i=1; i<=n; i++)
    {
        int k=-1,m=0;
        for(int j=1; j<=n; j++)
        {
            if(vis[j]==0 && dis[j]>m)
            {
                m=dis[j];
                k=j;
            }
        }
        vis[k]=1;
        for(int i=1; i<=n; i++)
        {
            if(dp[k][i])
                dis[i]=max(dis[i],min(dis[k],dp[k][i]));
        }
    }
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        int u,v,w;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            dp[u][v]=dp[v][u]=w;
        }
        dy();
        if(sum) puts("");
        printf("Scenario #%d:\n",++sum);
        printf("%d\n",dis[n]);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值