UVA 10340 - All in All 水~

看题传送门

Problem E

All in All

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

You have devised a new encryption technique whichencodes a message by inserting between its characters randomly generatedstrings in a clever way. Because of pending patent issues we will not discussin detail how the strings are generated and inserted into the original message.To validate your method, however, it is necessary to write a program thatchecks if the message is really encoded in the final string.

Given two strings s and t, you haveto decide whether s is a subsequence oft, i.e. if you can removecharacters fromt such that the concatenation of the remainingcharacters iss.

Input Specification

The input contains several testcases. Each isspecified by two strings s, t of alphanumeric ASCII characters separatedby whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is asubsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

SampleOutput

Yes
No
Yes
No
 
 
 
 
题解:
 
 
 
 
水题哇~直接扫描一遍数组就好了,出现RE的话把数组开大就好了~
 
 
代码:
 
 
 
 
#include<cstdio>
#include<cstring>
const int MAXN=500000;
char a[MAXN],b[MAXN];
int main()
{
	while(scanf("%s%s",b,a)!=EOF)
	{
		int lena,lenb;
		lena=strlen(a);
		lenb=strlen(b);
		bool ok=true;
		int i=0,j=0;
		for(;i<lena&&j<lenb;i++)
			if(a[i]==b[j])
				j++;
		if(j!=lenb)
			ok=false;
		printf("%s\n",ok==true?"Yes":"No");
	}
}


转载于:https://www.cnblogs.com/murmured/p/5004302.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值