杭电-oj all in all

翻译:

Problem Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

你发明了一种新的加密技术它通过在字符之间插入随机生成的字符串来对消息进行编码以一种特别的方式。我们不会详细讨论字符串是如何生成并插入到原始消息中的因为未解决专利问题。为了验证你的方法,有必要编写一个程序来检查消息是否真的被编码在最后的字符串中

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

给你两个字符串s和t,你必须决定 s 是否是 t 的子序列,如果可以从 t 中移除字符,则其余字符的串联为 s

Input

The input contains s
l testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

输入包含几组测试数据,每个都是由两个由空格分隔的ASCII字符和数字构成的字符串s,t。s和t的长度不超过100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

如果是子串就输出Yes,如果不是输出No

Sample Input

sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output

Yes

No

Yes

No

代码:

#include<stdio.h>
#include<string.h>
int main()
{
    char s1[200000],s2[200000];
    int i,j;
    while (scanf("%s%s",s1,s2)!=EOF)
    {
        for (i=0,j=0; s1[i]!='\0'&&s2[j]!='\0'; j++)
            if (s1[i]==s2[j])
                ++i;
        if (s1[i]=='\0')
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值