poj3632

1.链接地址

https://vjudge.net/problem/POJ-3632

2.问题描述

 When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs. Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round? Long Street is a straight line, where all positions are integer. You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.

输入样例

2
4
24 13 89 37
6
7 30 41 14 39 42

输出样例

152
70

3.解题思路

排序找中间点即可。。。

4.算法实现源代码

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
int num[20];
int main(){
    int n,cases;   
    cin>>n;    
    for(int i=0;i<n;i++){
        cin>>cases;
        for(int j=0;j<cases;j++){
            cin>>num[j];
        }
        sort(num,num+cases); 
        cout<<2*(num[cases-1]-num[0])<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/KasenBob/p/11177026.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值