HDU 1673 题意难懂啊

Optimal Parking

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2659    Accepted Submission(s): 2231


Problem Description
When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.
Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?
Long Street is a straight line, where all positions are integer.
You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.
 

Input
The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second gives their n integer positions on Long Street, 0 <= xi <= 99.
 

Output
Output for each test case a line with the minimal distance Michael must walk given optimal parking.
 

Sample Input
  
  
2 4 24 13 89 37 6 7 30 41 14 39 42
 

Sample Output
  
  
152 70
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1677  1678  1671  1676  1672 
 

题意难懂啊,意思就是把车停在一个位置,让你计算走过的路程的最小值,肯定把车停在这些shop之间,距离就是离得远的两个店铺的距离二倍,不算在店铺里逛的路程。。。。
ac代码
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
#include <stack> 

using namespace std;
const int MAX=20+5;
int t;
int n;
int a[MAX]; 
int main()
{
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%d",a+i);
		}
		sort(a,a+n);
		printf("%d\n",(a[n-1]-a[0])*2);
	}
	
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值