B - Median Pyramid Easy 构造题

B - Median Pyramid Easy


Time limit : 2sec / Memory limit : 256MB

Score : 400 points

Problem Statement

We have a pyramid with N steps, built with blocks. The steps are numbered 1 through N from top to bottom. For each 1≤iN, step i consists of 2i−1 blocks aligned horizontally. The pyramid is built so that the blocks at the centers of the steps are aligned vertically.

A pyramid with N=4 steps

Snuke wrote a permutation of (122N−1) into the blocks of step N. Then, he wrote integers into all remaining blocks, under the following rule:

  • The integer written into a block b must be equal to the median of the three integers written into the three blocks directly under b, or to the lower left or lower right of b.

Writing integers into the blocks

Afterwards, he erased all integers written into the blocks. Now, he only remembers that the integer written into the block of step 1 was x.

Construct a permutation of (122N−1) that could have been written into the blocks of step N, or declare that Snuke's memory is incorrect and such a permutation does not exist.

Constraints

  • 2≤N≤105
  • 1≤x≤2N−1

Input

The input is given from Standard Input in the following format:

N x

Output

If no permutation of (122N−1) could have been written into the blocks of step N, print No.

Otherwise, print Yes in the first line, then print 2N−1 lines in addition.

The i-th of these 2N−1 lines should contain the i-th element of a possible permutation.


Sample Input 1

4 4

Sample Output 1

Yes
1
6
3
7
4
5
2

This case corresponds to the figure in the problem statement.


Sample Input 2

2 1

Sample Output 2

No

No matter what permutation was written into the blocks of step N, the integer written into the block of step 1 would be 2.


Submit

 

思路:

要使得最上面的数是x。那么,特判完特殊情况后。(就是输出NO的,)

如果x==1或者x==2*n-1是不行的,因为他们不可能是中间数。不能弄上去。

否则我们尽可能使得倒数第二行得x个数尽量多。

这样是最优的。

比如x=4 n = 4

那么应该是1 6 3 4 5 2 7

有三个4弄上去了

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#define IOS ios::sync_with_stdio(false)
using namespace std;
#define inf (0x3f3f3f3f)
typedef long long int LL;
 
#include <iostream>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include <queue>
#include <string>
 
const int maxn = 2e5 + 20;
int a[maxn];
bool book[maxn];
void work() {
    int n, x;
    scanf("%d%d", &n, &x);
    if (x == 1 || x == 2 * n - 1) {
        printf("No\n");
        return;
    }
    int t = 2 * n - 1;
    a[t / 2 + 1] = x;
    a[t / 2] = x - 1;
    a[t / 2 + 2] = x + 1;
    book[x] = book[x - 1] = book[x + 1] = 1;
    if (t / 2 - 1 > 0 && x + 2 <= t) {
        a[t / 2 - 1] = x + 2;
        book[x + 2] = 1;
    }
    if (t / 2 + 3 <= t && x - 2 >= 1) {
        a[t / 2 + 3] = x - 2;
        book[x - 2] = 1;
    }
    int to = 1;
    for (int i = 1; i <= t; ++i) {
        if (a[i] != 0) continue;
        while (book[to] != 0) to++;
        a[i] = to;
        book[to] = 1;
    }
    printf("Yes\n");
    for (int i = 1; i <= t; ++i) {
        printf("%d\n", a[i]);
    }
}
 
int main() {
#ifdef local
    freopen("data.txt","r",stdin);
#endif
    work();
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/liuweimingcprogram/p/6011940.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值