hdoj--1034--Hidden String(dfs)

Hidden String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1677    Accepted Submission(s): 589



Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, gets a string s of length n. He wants to find three nonoverlapping substrings s[l1..r1], s[l2..r2], s[l3..r3] that:

1. 1l1r1<l2r2<l3r3n

2. The concatenation of s[l1..r1], s[l2..r2], s[l3..r3] is "anniversary".
 

Input
There are multiple test cases. The first line of input contains an integer T (1T100), indicating the number of test cases. For each test case:

There's a line containing a string s (1|s|100) consisting of lowercase English letters.
 

Output
For each test case, output "YES" (without the quotes) if Soda can find such thress substrings, otherwise output "NO" (without the quotes).
 

Sample Input
 
  
2 annivddfdersewwefary nniversarya
 

Sample Output
 
  
YES NO
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5594  5593  5592  5591  5590

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char str[1010],op[13]={"anniversary"};
int flog,l,L;
void dfs(int b1,int b2,int num)
{
	int i;
	if(b2>=11&&num<=3)
	{
		flog=1;
		return ;
	}
	if(num>3)
	return ;
	if(b1>=l||flog)
	return ;
	for(i=b1;i<l;i++)
	{
		int x=i;
		int y=b2;
		while(str[x]==op[y]&&x<l&&y<11)
		{
			x++,y++;
		}
		dfs(x+1,y,num+1);
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		L=strlen(op);
		memset(str,'\0',sizeof(str));
		scanf("%s",str);
		flog=0;
		l=strlen(str);
		dfs(0,0,0);
		if(flog)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
}

 

转载于:https://www.cnblogs.com/playboy307/p/5273641.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值