HDOJ-----5311---Hidden String---暴力

Hidden String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1961    Accepted Submission(s): 731


Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, gets a string s of length n . He wants to find three nonoverlapping substrings s[l1..r1] , s[l2..r2] , s[l3..r3] that:

1. 1l1r1<l2r2<l3r3n

2. The concatenation of s[l1..r1] , s[l2..r2] , s[l3..r3] is "anniversary".
 

Input
There are multiple test cases. The first line of input contains an integer T (1T100) , indicating the number of test cases. For each test case:

There's a line containing a string s (1|s|100) consisting of lowercase English letters.
 

Output
For each test case, output "YES" (without the quotes) if Soda can find such thress substrings, otherwise output "NO" (without the quotes).
 

Sample Input
  
  
2 annivddfdersewwefary nniversarya
 

Sample Output
  
  
YES NO
给一串字符,问能不能找出三段拼接在一块拼成anniversary,只能暴力查找了

#include<cstdio>
#include<iostream>
#include<cstring>
#define LL long long
using namespace std;
char s[110], m[20] = "anniversary";
bool solve(){
	int c = strlen(s+1);
	for(int i = 1; i <= 9; i++){//分为三段,i是一段,j-i是一段,11-j是一段
		for(int j = i+1; j <= 10; j++){
			int r = 1;
			while(r <= c && strncmp(m, s+r, i)) r++;//检查第一段是否满足
			if(r == c) continue;
			r += i;
			while(r <= c && strncmp(m+i, s+r, j-i)) r++;
			if(r == c) continue;
			r += j-i;
			while(r <= c && strncmp(m+j, s+r, 11-j)) r++;
			if(r <= c) return true; 
		}
	}
	return false;
}
int main(){
	int t, n;
	cin >> t;
	while(t--){
		cin >> s+1;
		printf(solve() ? "YES\n" : "NO\n");
	}
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值