杭电 2830 数学题

         题目:

Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 512    Accepted Submission(s): 346


Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

Output
Output one line for each test case, indicating the maximum possible goodness.
 

Sample Input
 
  
3 4 1011 1001 0001 3 4 1010 1001 0001
 

Sample Output
 
  
4 2 Note: Huge Input, scanf() is recommended.
 
ac代码:
/*用a[i]代表矩形的宽,用t代表矩形的长,则两者
的积就是矩形的面积。用sort对b数组排序的过程其
实就是交换列的过程。
*/
#include <iostream>
#include <algorithm>
#include <string.h>
#include <string>
using namespace std;
#define M 1010
int a[M],b[M];
char ch[M];
void init(){
  memset(a,0,sizeof(a));
  memset(b,0,sizeof(b));
  memset(ch,0,sizeof(ch));
}
int main(){
  int n,m;
  while(~scanf("%d%d",&n,&m)){
    init();
	int ans=0;
	for(int i=0;i<n;++i){
	  scanf("%s",ch);
	  for(int j=0;j<m;++j){
	    if(ch[j]=='1')
			a[j]++;
		else
			a[j]=0;//如果列上的1不连续的话,则宽为0
	  }
	  for(int j=0;j<m;++j)
		  b[j]=a[j];
	  sort(b,b+m);
	  int t=-1,sum=0;
	  for(int j=0;j<m;++j){
		  if(t!=b[j]){
		    t=b[j];
			sum=t*(m-j);
			if(sum>ans)
				ans=sum;
		  }
	  }
	}
	printf("%d\n",ans);
  }
  return 0;
}


转载于:https://www.cnblogs.com/javaspring/archive/2012/02/28/2656395.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值