杭电2830 最大子矩阵

Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1772    Accepted Submission(s): 1178


Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

Output
Output one line for each test case, indicating the maximum possible goodness.
 

Sample Input
  
  
3 4 1011 1001 0001 3 4 1010 1001 0001
 

Sample Output
  
  
4 2 Note: Huge Input, scanf() is recommended.
 

题意:一个矩阵,任意两列可以交换,求出全为1的最大子矩阵。

思路:最初思路是按照求最大子矩阵和模板那种思路,但最后实现有很多情况不满足。看了大神们的思路后,发现可以用两个数组,num[i]表示满足以i为最大高度的列数,h[j]表示每一列的最大高度。然后一行一行往下扫,求出全为1的最大子矩阵。

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define M(x) memset(x,0,sizeof(x));
using namespace std;
int h[1005],num[1005],m,n;
int main()
{
    //freopen("D://in.txt","r",stdin);
    int max1;
    char cc;
    while(~scanf("%d %d",&n,&m))
    {
        max1=0;
        M(h);
        for(int i=0;i<n;i++)
        {
            getchar();
            M(num);
            for(int j=0;j<m;j++)
            {
                scanf("%c",&cc);
                if(cc=='1')
                    h[j]++;
                else
                    h[j]=0;
                num[h[j]]++;
                for(int k=1;k<h[j];k++)
                    num[k]++;
            }
            for(int k=1; k<=1000; k++)
                max1=max(max1,num[k]*k);
        }
        cout<<max1<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值