hdu 1907 John&& hdu 2509 Be the Winner(基础nim博弈)

Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

 

Sample Input
2 3 3 5 1 1 1
 

 

Sample Output
John Brother
 
//第一道nim博弈题
// T异或为0 S异或为1
//必胜态:T0态,S1态,S2态必胜
//必败态:S0态,T2态必输
 
 
#include <iostream>

using namespace std;

int main()
{
    int t,n;
    int sum1,sum2,ans;
    int a[50];
    cin>>t;
    while(t--)
    {
        cin>>n;
        sum1=0;
        sum2=0;
        ans=0;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
            ans=ans^a[i];
            if(a[i]>=2)
            sum2++;//富裕堆
            else
            sum1++;//孤单堆
        }
        if((ans&&sum2)||(!ans&&!sum2))
        cout<<"John"<<endl;
        if((ans&&sum1%2!=0&&sum2==0)||(!ans&&sum2>=2))
        cout<<"Brother"<<endl;
    }
    return 0;
}

 

Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 

 

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 

 

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 

 

Sample Input
2 2 2 1 3
 

 

Sample Output
No Yes
 
#include <iostream>

using namespace std;

int main()
{
    int n,ans,sum1,sum2;
    int a[105];
    while(cin>>n)
    {
        sum1=sum2=ans=0;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
            ans=ans^a[i];
            if(a[i]>=2)
            sum2++;
            else
            sum1++;
        }
        if((ans&&sum2)||(!ans&&!sum2))
        cout<<"Yes"<<endl;
        if((ans&&sum1%2!=0&&sum2==0)||(!ans&&sum2>=2))
        cout<<"No"<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/nefu929831238/p/6118376.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值