hdu2509 Be the Winner (反尼姆博弈 )

hdu2509 Be the Winner

Problem Description
Let’s consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example “@@@” can be turned into “@@” or “@” or “@ @”(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

Output
If a winning strategies can be found, print a single line with “Yes”, otherwise print “No”.

Sample Input
2
2 2
1
3

Sample Output
No
Yes

Source
ECJTU 2008 Autumn Contest

题解: 根据题意最后取完的人失败,可以看出这是一题反尼姆博弈,也是模板题。

我们可以参考这张图片理解反尼姆博弈。
在这里插入图片描述
根据这张图片我们可以进行总结。令ans为所有堆的异或和,cnt为充裕堆的数量。由上述可知T0,S1,S2状态下先手必胜。
T0:ans==0 && cnt == 0;
S1:ans!=0 && cnt == 1;
S2:ans!=0 && cnt >= 2;
由上可知当先手必胜时 ** ans == 0 && cnt == 0 || ans != 0 && cnt! =0 **

#include<list>
#include<string.h>
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<vector>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e4 + 10;
const int inf = 0x3f3f3f3f;
const int Base =131;
const ll INF = 1ll << 62;
//const double PI = acos(-1);
const double eps = 1e-7;
const int mod = 1e9+7;
#define speed {ios::sync_with_stdio(false);cin.tie(0);cout.tie(0); }



int main()
{
	int n;
	while(~scanf("%d",&n))
	{	
		int ans=0,cnt=0,x;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&x);
			ans^=x;
			if(x>1)cnt++;
		}
		if(ans==0&&cnt==0||ans!=0&&cnt!=0)
			printf("Yes\n");
		else printf("No\n");
	}
    system("pause");
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值