Prerequisites?[HDU1144]

Prerequisites?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1220 Accepted Submission(s): 698


Problem Description
Freddie the frosh has chosen to take k courses. To meet the degree requirements, he must take courses from each of several categories. Can you assure Freddie that he will graduate, based on his course selection?

 

Input
Input consists of several test cases. For each case, the first line of input contains 1 ≤ k ≤ 100, the number of courses Freddie has chosen, and 0 ≤ m ≤ 100, the number of categories. One or more lines follow containing k 4-digit integers follow; each is the number of a course selected by Freddie. Each category is represented by a line containing 1 ≤ c ≤ 100, the number of courses in the category, 0 ≤ r ≤ c, the minimum number of courses from the category that must be taken, and the c course numbers in the category. Each course number is a 4-digit integer. The same course may fulfil several category requirements. Freddie's selections, and the course numbers in any particular category, are distinct. A line containing 0 follows the last test case.

 

Output
For each test case, output a line containing "yes" if Freddie's course selection meets the degree requirements; otherwise output "no."

 

Sample Input
3 2
0123 9876 2222
2 1 8888 2222
3 2 9876 2222 7654
3 2
0123 9876 2222
2 2 8888 2222
3 2 7654 9876 2222
0

Sample Output
yes
no

#include<stdio.h>
int main()
{
    int k,m,c,r,d,i,j,l,flag,res,a[102];
    while(scanf("%d%d",&k,&m),k)
    {
        flag=1;
        for(i=0;i<k;i++)
            scanf("%d",&a[i]);
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&c,&r);
            res=0;
            for(j=0;j<c;j++)
            {
                scanf("%d",&d);
                for(l=0;l<k;l++)
                    if(d==a[l])
                        res++;
            }
            if(res>=r)
                continue;
            else
                flag=0;
        }
        if(flag)
            printf("yes\n");
        else    
            printf("no\n");
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/dramstadt/p/6087063.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值