hdu 1144 Prerequisites

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1144

题目描述:

Prerequisites?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 900    Accepted Submission(s): 561


Problem Description
Freddie the frosh has chosen to take k courses. To meet the degree requirements, he must take courses from each of several categories. Can you assure Freddie that he will graduate, based on his course selection? 
 

Input
Input consists of several test cases. For each case, the first line of input contains 1 ≤ k ≤ 100, the number of courses Freddie has chosen, and 0 ≤ m ≤ 100, the number of categories. One or more lines follow containing k 4-digit integers follow; each is the number of a course selected by Freddie. Each category is represented by a line containing 1 ≤ c ≤ 100, the number of courses in the category, 0 ≤ r ≤ c, the minimum number of courses from the category that must be taken, and the c course numbers in the category. Each course number is a 4-digit integer. The same course may fulfil several category requirements. Freddie's selections, and the course numbers in any particular category, are distinct. A line containing 0 follows the last test case.
 

Output
For each test case, output a line containing "yes" if Freddie's course selection meets the degree requirements; otherwise output "no." 
 

Sample Input
  
  
3 2 0123 9876 2222 2 1 8888 2222 3 2 9876 2222 7654 3 2 0123 9876 2222 2 2 8888 2222 3 2 7654 9876 2222 0
 

Sample Output
  
  
yes no

题意:

选课,要选k门课,每门课给出课程号,有m类课程,每类课程有c个课程,在该类课程至少要选r门课程才能达到学分,问给出相应课程,课程类,课程号是否能达到学分。

题解:

每一类只要满足r门课程的数量即可,即每个样例的第3~m行 每行都要满足r门课程的选择就可通过,只要有一行没有通过的就是不能通过。而满足这个r门课程根据课程号来匹配,是否在3~m行选的这些课程号涉及到了第2行的课程,若涉及到了说明满足一门,所以passcnt++(见代码)

代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
using namespace std;
int course[100]={0};
int k=0,m=0,c=0,r=0;
int cates[100]={0};
int main()
{
    while(scanf("%d",&k)!=EOF&&k>0)
    {
        int flag=1;//initialize the case is available
        scanf("%d",&m);
        for(int i=0;i<=k-1;i++)
        {
            scanf("%04d",&course[i]);
        }
        for(int i=0;i<=m-1;i++)
        {
            scanf("%d%d",&c,&r);
            int passcnt=0;
            for(int j=0;j<=c-1;j++)
            {
                int degree=0;
                scanf("%d",°ree);
                for(int x=0;x<=k-1;x++)
                {
                    if(course[x]==degree)
                    {
                        passcnt++;
                    }
                }
            }
            if(passcnt<r)
            {
                flag=0;
            }
        }
        if(!flag)
        {
            printf("no\n");
        }
        else
        {
            printf("yes\n");
        }
    }
    return(0);
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值