hdu-5703 Desert(水题)

题目链接:

Desert

Time Limit: 2000/1000 MS (Java/Others)    

Memory Limit: 65535/32768 K (Java/Others)


Problem Description
 
A tourist gets lost in the desert with n liters of water. He drinks positive integer units of water each day.

Write a program to calculate how many different ways the tourist can drink up the water.
 

 

Input
 
The first line contains the number of test cases  T(T10).
Next T lines contain the number n(1n1000000) for each test case.
 

 

Output
 
Output consists of  T lines.
Each line contains the binary number which represents number of different ways to finish up the water specified in the test case.
 

 

Sample Input
 
1
3
 

 

Sample Output
 
100
 
题意:
 
n是多少个不同序列的和?
 
思路:
 
可以发现是2^(n-1)种;
 
AC代码:
#include <bits/stdc++.h>
/*
#include <iostream>
#include <queue>
#include <cmath>
#include <map>
#include <cstring>
#include <algorithm>
#include <cstdio>
*/
using namespace std;
#define Riep(n) for(int i=1;i<=n;i++)
#define Riop(n) for(int i=0;i<n;i++)
#define Rjep(n) for(int j=1;j<=n;j++)
#define Rjop(n) for(int j=0;j<n;j++)
#define mst(ss,b) memset(ss,b,sizeof(ss));
typedef long long LL;
const LL mod=1e9+7;
const double PI=acos(-1.0);
const LL inf=1e18;
const int N=1e6+4;
int n,q;
int main()
{
    int t;
    scanf("%d",&t);
      while(t--)
      {
          scanf("%d",&n);
          n--;
          printf("1");
          while(n--)printf("0");
          printf("\n");
      }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/zhangchengc919/p/5538707.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值