hdu 5703 Desert

                                                    Desert

                                                        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
                                                        Total Submission(s): 976    Accepted Submission(s): 712


Problem Description
A tourist gets lost in the desert with n liters of water. He drinks positive integer units of water each day.

Write a program to calculate how many different ways the tourist can drink up the water.
 

Input
The first line contains the number of test cases T(T10) .
Next T lines contain the number n(1n1000000) for each test case.
 

Output
Output consists of T lines.
Each line contains the binary number which represents number of different ways to finish up the water specified in the test case.
 

Sample Input
  
  
1 3
 

Sample Output
  
  
100
Hint
3 liters of water can be comsumed in four different ways show in the following. 1. 1 1 1 2. 1 2 3. 2 1 4. 3 If we write 4 in binary, it's 100.
 简要题意及分析:
一个人有n升水,每天喝掉k(k<=n)升水,问一共有多少种不同的方法。
采用隔板法,把正整数n拆分成n个1,然后产生n-1的空,向这些空插入隔板,共有C(n-1,0)+C(n-1,1)+C(n-1,2)...+C(n-1,n-1)=pow(2,n-1)种方法。
注意数据规模过大,而且题目要求输出二进制数。由于2的整数幂的二进制表示具有特殊性,即2^n-1用二进制表示即为1后面跟着n-1个0,循环输出即可。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        int i;
        for(i=0;i<n;++i)
        printf("%d",i==0?1:0);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值