POJ 1466 大学谈恋爱 二分匹配变形 最大独立集

Girls and Boys
Time Limit: 5000MS Memory Limit: 10000K
Total Submissions: 11694 Accepted: 5230

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

the number of students 
the description of each student, in the following format 
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 
or 
student_identifier:(0) 

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

Source

题意:在大学校园里男女学生存在某种关系,现在给出学生人数n,并给出每个学生与哪些学生存在关系(存在关系的学生一定是异性)。现在让你求一个学生集合,这个集合中任意两个学生之间不存在这种关系。输出这样的关系集合中最大的一个的学生人数。
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <cmath>
#include <vector>
using namespace std;

vector<int> G[505];
int match[505],used[505];
int n;
void add_edge(int u,int v)
{
    G[u].push_back(v);
    G[v].push_back(u);
}

bool dfs(int u)
{
     used[u]=1;
     for(int i=0;i<G[u].size();i++)
     {
       int v=G[u][i];
       int w=match[v];
       if(w<0||!used[w]&&dfs(w))
         {
             match[u]=v;
             match[v]=u;//匹配的边两端点同时标记
             return true;
         }
     }
     return false;
}

int  bipartite_match()
{
    memset(match,-1,sizeof(match));
    int res=0;
    for(int i=0;i<n;i++)
      if(match[i]<0)//先前标记过就不用再标记了
      {
          memset(used,0,sizeof(used));
          if(dfs(i)) res++;
      }
    return res;
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++) G[i].clear();
        for(int u=0;u<n;u++)
        {
           int k,num,v;
           scanf("%d: (%d)",&k,&num);
           for(int i=0;i<num;i++)
           {
               scanf("%d",&v);
               add_edge(u,v);
           }
        }
        printf("%d\n",n-bipartite_match());
    }
    return 0;
}

  分析:最大独立集问题,看得这篇介绍http://blog.sina.com.cn/s/blog_6635898a0100lyui.html

 

    他们写的模板最后二分匹配出来后都要除以2,因为每条边都重复算了一次,但是因为我的模板

的问题,不需要除以2,因为同时把匹配的边两顶点都标记了

          最大独立集=顶点数-匹配的顶点数/2(我的模板中即bipartite_match()返回的边数)

转载于:https://www.cnblogs.com/smilesundream/p/5500857.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值