HDOJ 1068 Girls and Boys (最大匹配数 匈牙利算法)

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10636    Accepted Submission(s): 4934


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
  
  
5 2
 
题意:一些男生和女生存在浪漫关系。现需要求最大的集合,在这个集合里任意两个人都不存在浪漫关系。

分析:男生人数+女生人数-最大匹配中边的数目。

题目没有区分男女生,所以理解为有0~n编号的男生和0~n编号的女生。所求最大匹配/2就可以了。

#include<cstdio>
#include<algorithm>
#include<vector>
#include<iostream>
#include<cstring>
using namespace std;
const int maxn  = 550;
vector <int>G[maxn];
bool inpath[maxn]; //标记
int match[maxn];
int n;
bool findpath(int k){
    for(int i=0;i<G[k].size();i++){
        int v = G[k][i];
        if(!inpath[v]){
            inpath[v]=true;
            if(match[v] == -1 || findpath(match[v])){ //如果没有匹配,或者可以为 当前已经匹配的v匹配的k,再找一个匹配。
                match[v]=k; return true;
            }
        }
    }
    return false;
}
void hungary(){
    int cnt=0;
    for(int i=0;i<n;i++){
        memset(inpath,0,sizeof(inpath));
        if(findpath(i)){
            cnt++;
        }
    }
    cout<< n - cnt / 2 <<endl;
}
void init(){
    memset(inpath,false,sizeof(inpath));
    memset(match,-1,sizeof(match));
    for(int i=0;i<maxn;i++){
        G[i].clear();
    }
}
int main(){
    int a, b, c;
    while (cin >> n){
        init();
        for (int i = 0; i < n; i++){
            scanf("%d: (%d)", &a, &b);
            for (int j = 0; j < b; j++){
                cin >> c;
                G[a].push_back(c);
                //G[c].push_back(a);    //令我感到奇怪的是这句话加上也可以过,为什么??
            }
        }
        hungary();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值