hdoj--4325--Flowers(线段树+二分)

Flowers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2585    Accepted Submission(s): 1271


Problem Description
As is known to all, the blooming time and duration varies between different kinds of flowers. Now there is a garden planted full of flowers. The gardener wants to know how many flowers will bloom in the garden in a specific time. But there are too many flowers in the garden, so he wants you to help him.
 

Input
The first line contains a single integer t (1 <= t <= 10), the number of test cases.
For each case, the first line contains two integer N and M, where N (1 <= N <= 10^5) is the number of flowers, and M (1 <= M <= 10^5) is the query times.
In the next N lines, each line contains two integer S i and T i (1 <= S i <= T i <= 10^9), means i-th flower will be blooming at time [S i, T i].
In the next M lines, each line contains an integer T i, means the time of i-th query.
 

Output
For each case, output the case number as shown and then print M lines. Each line contains an integer, meaning the number of blooming flowers.
Sample outputs are available for more details.
 

Sample Input
 
  
2 1 1 5 10 4 2 3 1 4 4 8 1 4 6
 

Sample Output
 
  
Case #1: 0 Case #2: 1 2 1
 

Author
BJTU
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define MAX 100000
struct tree
{
	int l,r;
	int m;
}num[MAX*10];
void build(int node,int l,int r)
{
	num[node].l=l;
	num[node].r=r;
	num[node].m=0;
	if(l==r)
	return ;
	int mid=(l+r)/2;
	build(node*2,l,mid);
	build(node*2+1,mid+1,r);
}
void updata(int node,int l,int r)
{
	if(num[node].l==l&&num[node].r==r)
	{
		num[node].m++;
		return ;
	}
	int mid=(num[node].l+num[node].r)/2;
	if(r<=mid)
	updata(node*2,l,r);
	else if(l>mid)
	updata(node*2+1,l,r);
	else 
	{
		updata(node*2,l,mid);
		updata(node*2+1,mid+1,r);
	}
}
int query(int node,int l,int r)
{
	if(num[node].l==l&&num[node].r==r)
	{
		return num[node].m;
	}
	int mid=(num[node].l+num[node].r)/2;
	if(r<=mid)
	return query(node*2,l,r)+num[node].m;
	else 
	{
		if(l>mid)
		return query(node*2+1,l,r)+num[node].m;
		else
		return query(node*2,l,mid)+query(node*2+1,mid+1,r);
	}
}
int main()
{
	int t;
	int Case=1;
	scanf("%d",&t);
	while(t--)
	{
		int m,n,x,y,z;
		scanf("%d%d",&n,&m);
		build(1,1,MAX);
		while(n--)
		{
			scanf("%d%d",&x,&y);
			updata(1,x,y);
		}
		printf("Case #%d:\n",Case++);
		while(m--)
		{
			scanf("%d",&z);
			printf("%d\n",query(1,z,z));
		}
	}
	return 0;
}

醉了醉了,二分都可以

<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define MAX  100010
int a[MAX],b[MAX];
int main()
{
	int t;
	int Case=1;
	scanf("%d",&t);
	while(t--)
	{
		int m,n,x,y,z;
		scanf("%d%d",&n,&m);
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(int i=0;i<n;i++)
		scanf("%d%d",&a[i],&b[i]);
		sort(a,a+n);sort(b,b+n);
		printf("Case #%d:\n",Case++);
		for(int i=0;i<m;i++)
		{
			scanf("%d",&z);
			x=upper_bound(a,a+n,z)-a;
			y=lower_bound(b,b+n,z)-b;
			printf("%d\n",x-y);
		}
	}
	return 0;
}


 
  

转载于:https://www.cnblogs.com/playboy307/p/5273722.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值