HDOJ 4325 —— 树状数组 + 离散化

Flowers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1981    Accepted Submission(s): 974


Problem Description
As is known to all, the blooming time and duration varies between different kinds of flowers. Now there is a garden planted full of flowers. The gardener wants to know how many flowers will bloom in the garden in a specific time. But there are too many flowers in the garden, so he wants you to help him.
 

Input
The first line contains a single integer t (1 <= t <= 10), the number of test cases.
For each case, the first line contains two integer N and M, where N (1 <= N <= 10^5) is the number of flowers, and M (1 <= M <= 10^5) is the query times. 
In the next N lines, each line contains two integer S i and T i (1 <= S i <= T i <= 10^9), means i-th flower will be blooming at time [S i, T i].
In the next M lines, each line contains an integer T i, means the time of i-th query.
 

Output
For each case, output the case number as shown and then print M lines. Each line contains an integer, meaning the number of blooming flowers.
Sample outputs are available for more details.
 

Sample Input
  
  
2 1 1 5 10 4 2 3 1 4 4 8 1 4 6
 

Sample Output
  
  
Case #1: 0 Case #2: 1 2 1
 

Author
BJTU
 

Source
 

Recommend
zhoujiaqi2010
 
离线查询,所以先把端点和查询点离散化。然后根据树状数组的插线问点即可。
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>

using namespace std;
//#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid  , rt << 1
#define rson mid + 1 , r , rt << 1 | 1
//#define mid ((l + r) >> 1)
#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 1000000 + 50;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
#define eps 1e-8
#define mod 1000000007
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pi;
///#pragma comment(linker, "/STACK:102400000,102400000")
int c[MAXN] , fl[MAXN << 2] , q[MAXN];
struct Node
{
    int st , en;
}site[MAXN];
int lowbit(int x)
{
    return x & ( -x);
}
void update(int x , int value , int n)
{
    while(x <= n)
    {
        c[x] += value;
        x += lowbit(x);
    }
}
int getsum(int x)
{
    int sum = 0;
    while(x > 0)
    {
        sum += c[x];
        x -= lowbit(x);
    }
    return sum;
}
int main()
{
    //ios::sync_with_stdio(false);
    #ifdef Online_Judge
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif // Online_Judge
    int t , n , nn, m;
    scanf("%d" , &t);
    FORR(kase , 1 , t)
    {

        scanf("%d%d" , &n , &m);
        int num = 0;
        clr(site , 0);
        clr(fl , 0);
        clr(c , 0);
        FOR(i , 0 , n)
        {
            scanf("%d%d" ,&site[i].st , &site[i].en);
            fl[num++] = site[i].st;
            fl[num++] = site[i].en;
        }
        FOR(i , 0 , m)
        {
            scanf("%d" , &q[i]);
            fl[num++] = q[i];
        }
//        outstars
        sort(fl , fl + num);
        num = unique(fl  , fl + num) - fl;
        FOR(i ,0 , n)
        {
            int x = lower_bound(fl , fl + num , site[i].st) - fl;
            int y = lower_bound(fl , fl + num , site[i].en) - fl;
            update(x + 1 , 1 , num),update(y + 2, -1 , num);
        }

        printf("Case #%d:\n", kase);
        FOR(i ,0 , m)
        {
            int x = lower_bound(fl , fl + num , q[i]) - fl + 1;
            printf("%d\n" ,getsum(x));
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值