hdu5878-I Count Two Three

Problem Description

I will show you the most popular board game in the Shanghai Ingress Resistance Team.
It all started several months ago.
We found out the home address of the enlightened agent Icount2three and decided to draw him out.
Millions of missiles were detonated, but some of them failed.

After the event, we analysed the laws of failed attacks.
It's interesting that the i -th attacks failed if and only if i can be rewritten as the form of 2a3b5c7d which a,b,c,d are non-negative integers.

At recent dinner parties, we call the integers with the form 2a3b5c7d "I Count Two Three Numbers".
A related board game with a given positive integer n from one agent, asks all participants the smallest "I Count Two Three Number" no smaller than n .

 

 

Input

The first line of input contains an integer t (1≤t≤500000) , the number of test cases. t test cases follow. Each test case provides one integer n (1≤n≤109) .

 

 

Output

For each test case, output one line with only one integer corresponding to the shortest "I Count Two Three Number" no smaller than n .

 

 

Sample Input

 

10 1 11 13 123 1234 12345 123456 1234567 12345678 123456789

 

 

Sample Output

 

1 12 14 125 1250 12348 123480 1234800 12348000 123480000

    这道题目由于是2,3,5,7的次方,所以可能性不会太多,可以通过打表,然后二分查找的方法来解决

      AC:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
long long ans[1024000]={0};

int main()
{
    int t,cnt=1;
    scanf("%d",&t);
    long long n;
    for(int i=0;i<=30;i++)
            for(int j=0;j<=20;j++)
                for(int k=0;k<=15;k++)
                    for(int l=0;l<=11;l++)
                        if(i+j+k+l<32){
                            ans[cnt++]=pow(2,i)*pow(3,j)*pow(5,k)*pow(7,l);
                        }//打表后排序
    sort(ans,ans+cnt);
    while(t--)
    {
        scanf("%lld",&n);
        long long tmp=lower_bound(ans,ans+cnt,n)-ans;//二分查找大于或等于n的第一个数的位置
        printf("%lld\n",ans[tmp]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wangtao971115/p/10358315.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值