UVA 562 - Dividing coins 简单背包

 

  Dividing coins 

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.

 


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...

 


That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.

 


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

 

Input 

A line with the number of problems n, followed by n times:

  • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

 

Output 

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

 

Sample Input 

 

2
3
2 3 5
4
1 2 4 6

 

Sample Output 

 

0
1

 

 


Miguel A. Revilla 
1998-03-10
/*
 * Author:  
 * Created Time:  2013/10/14 23:00:22
 * File Name: B.cpp
 * solve: B.cpp
 */
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<string>
#include<map>
#include<stack>
#include<set>
#include<iostream>
#include<vector>
#include<queue>
//ios_base::sync_with_stdio(false);
//#pragma comment(linker, "/STACK:1024000000,1024000000")

using namespace std;
#define sz(v) ((int)(v).size())
#define rep(i, a, b) for (int i = (a); i < (b); ++i)
#define repf(i, a, b) for (int i = (a); i <= (b); ++i)
#define repd(i, a, b) for (int i = (a); i >= (b); --i)
#define clr(x) memset(x,0,sizeof(x))
#define clrs( x , y ) memset(x,y,sizeof(x))
#define out(x) printf(#x" %d\n", x)
#define sqr(x) ((x) * (x))
typedef long long LL;

const int INF = 1000000000;
const double eps = 1e-8;
const int maxn = 60000;

int sgn(const double &x) {  return (x > eps) - (x < -eps); }
int coin[maxn];
int dp[maxn];
int main() 
{
    //freopen("in.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int m;
        scanf("%d",&m);
        int sum = 0;
        repf(i,1,m)
        {
            scanf("%d",&coin[i]);
            sum += coin[i];
        }

        clr(dp);
        repf(i,1,m)
            repd(j,sum/2,0)
            if(j - coin[i] >= 0)
                dp[j] = max(dp[j],dp[j - coin[i]] + coin[i]);

        cout<<abs(dp[sum/2] - sum + dp[sum/2])<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/DreamHighWithMe/p/3369385.html

内容概要:本文详细介绍了利用COMSOL软件对人体皮肤温度场进行数值模拟的方法和技术细节。首先解释了COMSOL作为多物理场仿真的工具及其在生物医学工程领域的应用价值,然后逐步讲解了如何建立皮肤的几何模型,包括表皮层和真皮层的具体参数设置。接着探讨了物理场的选择与配置,如热传导方程、材料属性(导热系数)以及边界条件(对流换热系数、环境温度)。此外,还讨论了热源的引入方式,即通过代谢产热和血液灌注来模拟体内热量生成。最后,阐述了求解过程中的技巧,如网格划分、求解器设置,并展示了最终获得的人体皮肤温度分布云图及其实际意义。 适用人群:从事生物医学工程、热物理学等相关领域的科研工作者,尤其是那些希望深入了解人体皮肤温度场特性的研究人员。 使用场景及目标:适用于需要精确掌握人体皮肤温度分布的研究项目,例如皮肤生理功能探究、疾病诊断、药物递送系统设计等。通过对该模型的学习和应用,能够更好地理解皮肤细胞在正常运作代谢下的热环境,从而为相关研究提供理论依据和技术支持。 其他说明:文中不仅提供了详细的建模步骤指导,还包括了一些实用的小技巧,如参数化扫描、自适应网格划分等,有助于提高建模效率和准确性。同时,作者还分享了将模型应用于实际问题的经验,如降温面膜的设计、烧伤评估等,体现了该模型的广泛适用性和实用性。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值