CSU 1826 : Languages(map)

The Enterprise has encountered a planet that at one point had been inhabited. The only remnant from the prior civilization is a set of texts that was found. Using a small set of keywords found in various different languages, the Enterprise team is trying to determine what type of beings inhabited the planet.

Input

The first line of input will be N (1 ≤ N ≤ 100), the number of different known languages. The next N lines contain, in order, the name of the language, followed by one or more words in that language, separated with spaces. Following that will be a blank line. After that will be a series of lines, each in one language, for which you are to determine the appropriate language. Words consist of uninterrupted strings of upper or lowercase ASCII letters, apostrophes, or hyphens, as do the names of languages. No words will appear in more than one language. No line will be longer than 256 characters. There will be at most 1000 lines of sample text. Every sample text will contain at least one keyword from one of the languages. No sample text will contain keywords from multiple languages. The sample text may contain additional punctuation (commas, periods, exclamation points, semicolons, question marks, and parentheses) and spaces, all of which serve as delimiters separating keywords. Sample text may contain words that are not keywords for any specific language. Keywords should be matched in a case-insensitive manner.

Output

For each line of sample text that follows the blank line separating the defined languages, print a single line that identifies the language with which the sample text is associated.

Sample Input

4
Vulcan throks kilko-srashiv k'etwel
Romulan Tehca uckwazta Uhn Neemasta
Menk e'satta prah ra'sata
Russian sluchilos

Dif-tor heh, Spohkh. I'tah trai k'etwel
Uhn kan'aganna! Tehca zuhn ruga'noktan!

Sample Output

Vulcan
Romulan

题目大意是输入一定量的词汇库(字符串)(一种语言名和多种词汇呈映射关系)。再输入多组句子,其中每一句有且只有一种语言的词汇。将这句话的语言打印出来(特殊字符均为分隔符,字符不区分大小写)
可以用STR库中的map映射做,用getline整段文本,再用stringstream字符串流分割映射。最后枚举用count()即可。
源代码如下:

#include<iostream>
#include<map>
#include<string>
#include<sstream>

using namespace std;

int main() {
int t;
cin>>t;
string a,b,c;
map<string,string> m;
getchar();
for(int i=0;i<t;i++)
{
getline(cin,a);
stringstream txt(a);
txt>>b;
while(txt>>c)
{
for(int j=0;j<c.size();j++)
{
if(c[j]>='A'&&c[j]<='Z')
c[j]+=32;
}
m[c]=b;
}
}
while(getline(cin,a))
{
for(int i=0;i<a.size();i++)
if(a[i]==','||a[i]=='.'||a[i]=='!'||a[i]==';'||a[i]=='?'||a[i]=='('||a[i]==')')
a[i]=' ';
stringstream txt(a);
while(txt>>c)
{
for(int i=0;i<c.size();i++)
{
if(c[i]>='A'&&c[i]<='Z')
c[i]+=32;
}
if(m.count(c))
{
cout<<m[c]<<endl;
break;
}
}
}

return 0;
}

转载于:https://www.cnblogs.com/xibeiw/p/7239410.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值