BFS解决POJ 2386

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
 
  
View Code
#include "iostream"
#include "string"
using namespace std;
int used[105][105];
char map[105][105];
int direction[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
struct point
{
    int x;
    int y;
}queue[10005];
int si, sj, iColumn, iRow, count;
void bfs()
{
    int head = 0, tail = 0;
    used[si][sj] = 1;
    queue[head].x = si;  //搜索的初始x坐标
    queue[head].y = sj;  //搜索的初始y坐标
    head++;
    while(tail<head)
    {
        point temp1 = queue[tail];
        tail++;
        int k, m;
        for(k=0; k<8; k++)
        {
            point temp2;
            temp2.x = temp1.x+direction[k][0];  
            temp2.y = temp1.y+direction[k][1]; 
            if(temp2.x>=0 && temp2.x<iRow && temp2.y>=0 && temp2.y<iColumn && !used[temp2.x][temp2.y] && map[temp2.x][temp2.y]=='W')
            {
                used[temp2.x][temp2.y] = 1;
                queue[head] = temp2;
                head++;
            }
        }
    }
}
int main()
{
    int i, j;
    while(cin>>iRow>>iColumn)
    {
        memset(used, 0, sizeof(used));
        count=0;
        for(i=0; i<iRow; i++)
            for(j=0; j<iColumn; j++)
                cin>>map[i][j];
             for(i=0; i<iRow; i++)
            for(j=0; j<iColumn; j++)
            {
                if(map[i][j]=='W' && used[i][j]==0)  //一旦遇到了W,并且没有被访问过就bfs(),count++;
                {
                    si = i;
                    sj = j;
                    bfs();
                    count++;
                }
            }
        cout<<count<<endl;
    }
    return 0;
}

 

 
  
 

转载于:https://www.cnblogs.com/o8le/archive/2011/09/23/2186745.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值