POJ2386 Lake Counting【DFS、BFS】

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.

 解题思路

题目大意:N*M(100*100)的地图中,有‘.’和‘W’两种地图元素,问其中有多少个由‘W’构成的八连通块。

解题思路:这是一道比较基础的搜索题目,这道题采用DFS或BFS都可以,遍历地图中的所有点,如果遇到‘W’就开始使用DFS从其八个方向开始搜索,当遇到‘W’时就将该点改为‘.’并从该点继续搜寻,直到无法再找到‘W’为止。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

int dx[8] = { -1,-1,-1,0,0,1,1,1 };
int dy[8] = { -1,0,1,-1,1,-1,0,1 };

int n, m;
char map[110][110];

void DFS(int x, int y)
{
	if (x < 1 || x > n || y < 1 || y > m)			//越界
		return;
	if (map[x][y] != 'W')								//不属于连通块内
		return;     
	map[x][y]='.';										//已访问,改为背景
	for (int i = 0; i < 8; i++)
		DFS(x + dx[i], y + dy[i]);					//八连通dfs

}

int main()
{
	int cnt = 0;
	cin >> n >> m;
	for (int i = 1; i <= n; i++)
		for (int j = 1; j <= m; j++)
			cin >> map[i][j];
	for(int i = 1;i<=n;i++)
		for (int j = 1; j <= m; j++)
		{
			if (map[i][j] == 'W')
			{
				DFS(i, j);
				cnt++;
			}
		}
	cout << cnt << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值