hdu 4355

                                   Party All the Time


Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5278 Accepted Submission(s): 1636


Problem Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S3*W units if it walks a distance of S kilometers.
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.


Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x[i]<=x[i+1] for all i(1<=i<N). The i-th line contains two real number : Xi,Wi, representing the location and the weight of the i-th spirit. ( |xi|<=106, 0<wi<15 )


Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.


Sample Input

1
4
0.6 5
3.9 10
5.1 7
8.4 10



Sample Output

Case #1: 832


题意就是:在x轴上有一些点,并且这些点都有自己的权重,要你求sigma(|x-xi|^3*w)的最小值,因为对该函数求二阶导数后,其值大于等于0,所以可以用三分来求最小值。

<span style="font-size:18px;">
#include <iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int n;
double w[50005];
double a[50005];
double F(double x)
{
    double y=0;
    for(int i=0;i<n;i++)
    {
        double temp=fabs(x-a[i]);
        y+=pow(temp,3)*w[i];
    }
    return y;
}
double SanFen(double l,double r)//三分求最小值
{
    double mid,mmid;
    double fmid,fmmid;
    while(r-l>1e-4)
    {
        mid=(l+r)/2.0;
        mmid=(r+mid)/2.0;
        fmid=F(mid);
        fmmid=F(mmid);
        if(fmid+1e-4<fmmid)//由于该函数是凸函数,所以当fmid<fmmid时,将r向l靠近
            r=mmid;
        else
            l=mid;
    }
    return fmid;
}
int main()
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        double l=1000000,r=-1000000;
        for(int i=0;i<n;i++)//寻找区间的最大值与最小值
        {
            scanf("%lf%lf",&a[i],&w[i]);
            l=min(l,a[i]);
            r=max(r,a[i]);
        }
        printf("Case #%d:",cas++);
        printf(" %0.0lf\n",SanFen(l,r));//求最近的整数
    }
    return 0;
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值