hust1010 The Minimum Length

题目描述 There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A. 输入 Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000. 输出 For each line, output an integer, as described above. 样例输入
bcabcab
efgabcdefgabcde
样例输出
3

7

这题就是找最小的循环节是多少,直接用len-next[len]就行了。这里补充下next[i]的含义:1.指的是前i个字符前缀和后缀相同的匹配值。2.指的是如果s[i]不匹配,那么下一个要和当前字母匹配的字母的位置。next[i],i的范围是[0,n],不是[0,n-1].

#include<stdio.h>
#include<string.h>
char s[1000006];
int len,next[1000006];
void nextt()
{
	int i,j;
	i=0;j=-1;
	memset(next,-1,sizeof(next));
	while(i<len){
		if(j==-1 || s[i]==s[j]){
			i++;j++;next[i]=j;
		}
		else j=next[j];
	}
}

int main()
{
	int n,m,i,j,T;
	while(scanf("%s",s)!=EOF)
	{
		len=strlen(s);
		nextt();
		printf("%d\n",len-next[len]);
	}
	return 0;
}


转载于:https://www.cnblogs.com/herumw/p/9464750.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值