STL-Welcome to HDU to take part in the first CCPC girls' competition!-C++

Introduction

As a pretty special competition, many volunteers are preparing for it with high enthusiasm.
One thing they need to do is blowing the balloons.
Before sitting down and starting the competition, you have just passed by the room where the boys are blowing the balloons.

And you have found that the number of balloons of different colors are strictly different.After thinking about the volunteer boys' sincere facial expressions, you noticed that, the problem with more balloon numbers are sure to be easier to solve.

Now, you have recalled how many balloons are there of each color.Please output the solving order you need to choose in order to finish the problems from easy to hard.You should print the colors to represent the problems.

Input

The first line is an integer TT which indicates the case number.
And as for each case, the first line is an integer nn, which is the number of problems.
Then there are nn lines followed, with a string and an integer in each line, in the ii-th line, the string means the color of ballon for the ii-th problem, and the integer means the ballon numbers.
It is guaranteed that:

  • TT is about 100.
  • 1≤n≤101≤n≤10.
  • 1≤1≤ string length ≤10≤10.
  • 1≤1≤ bolloon numbers ≤83≤83.(there are 83 teams :p)
  • For any two problems, their corresponding colors are different.
  • For any two kinds of balloons, their numbers are different.

Output

For each case, you need to output a single line.
There should be nn strings in the line representing the solving order you choose.
Please make sure that there is only a blank between every two strings, and there is no extra blank.

Sample Input

3
3
red 1
green 2
yellow 3
1
blue 83
2
red 2
white 1

Sample Output​​​​​​​

yellow green red
blue
red white

代码

分析:结构体数组设置+SORT函数排序+确定排序类型(升序还是降序)

#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <math.h>

//设置结构体,开大数组 begin是给vector用的。
using namespace std;
struct node{
    string color;
    int num; 
}haha[500];
bool cmp(node a,node b){
    return a.num>b.num;
}
int main(){
    int t,lunci;
    cin>>t;
    getchar();
    for(int i = 0;i < t;i++){
        cin>>lunci;
        getchar();
        for(int i = 0;i < lunci;i++){
            cin>>haha[i].color>>haha[i].num;
        }
        sort(haha,haha+lunci,cmp);
        cout<<haha[0].color;
        for(int i = 1;i < lunci;i++){
            cout<<" ";
            cout<<haha[i].color;
        }
        cout<<endl;
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值