HDU 5702 Solving Order

Solving Order

Description

Welcome to HDU to take part in the first CCPC girls’ competition!
MDZZ !

As a pretty special competition, many volunteers are preparing for it with high enthusiasm.
One thing they need to do is blowing the balloons.

Before sitting down and starting the competition, you have just passed by the room where the boys are blowing the balloons. And you have found that the number of balloons of different colors are strictly different.

After thinking about the volunteer boys’ sincere facial expressions, you noticed that, the problem with more balloon numbers are sure to be easier to solve.

Now, you have recalled how many balloons are there of each color.
Please output the solving order you need to choose in order to finish the problems from easy to hard.
You should print the colors to represent the problems.

Input

The first line is an integer T which indicates the case number.
And as for each case, the first line is an integer n, which is the number of problems.
Then there are n lines followed, with a string and an integer in each line, in the i-th line, the string means the color of ballon for the i-th problem, and the integer means the ballon numbers.

It is guaranteed that:
T is about 100.
1\leq n\leq 10.
1\leq string length \leq 10.
1\leq bolloon numbers \leq 83.(there are 83 teams :p)
For any two problems, their corresponding colors are different.
For any two kinds of balloons, their numbers are different.

Output

For each case, you need to output a single line.
There should be n strings in the line representing the solving order you choose.
Please make sure that there is only a blank between every two strings, and there is no extra blank.

Sample Input

3
3
red 1
green 2
yellow 3
1
blue 83
2
red 2
white 1

Sample Output

yellow green red
blue
red white


题意是给定不同颜色的气球名字和数目,将他们按数目从大到小输出名字
写的有点复杂了
运用了结构体、字符串的复制

AC

#include <bits/stdc++.h>
using namespace std;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        struct color
        {
            char s[100];
            int num;
        } a[n];
        for(int i=0; i<n; i++)
            scanf("%s%d",a[i].s,&a[i].num);
        for(int i=0; i<n-1; i++)
        {
            for(int j=0; j<n-i ; j++)
            {
                if(j<n-i-1)
                {
                    if(a[j].num<a[j+1].num)
                    {
                        int temp;char str[100];
                        temp=a[j].num;strcpy(str,a[j].s);
                        a[j].num=a[j+1].num;strcpy(a[j].s,a[j+1].s);
                        a[j+1].num=temp;strcpy(a[j+1].s,str);
                    }
                }

            }
        }
        for(int i=0; i<n; i++)
        {
            printf("%s",a[i].s);
            if(i!=n-1)
                printf(" ");
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值