南阳理工acm31题java_Abbreviation 英文词组缩写(来源:南阳理工大学ACM)java

Abbreviation

描述

As we know, we often use a short sequence of characters in place of some words with a very long name. For example, ACM is an abbreviation of “Association for Computing Machinery”. Now we are using an acronymic method to get the abbreviation. An acronym is generated from a long name by capitalizing the first letter of every word in the name and concatenating them together. There is an exception: some words are ignored when generating the abbreviation. These words( case insensitive) meet the following rules:

1. The common words “and”, “for”, and “the”.

2. The words with length less than 3, such as “a”, “of”, “to”. Your job is to get the abbreviation of a given string by using the acronymic method.

输入

Input starts with an integer T (T <= 100), denoting the number of test cases. Each case contains a line with several words seperated by space(s). The length of each line is less than 100. And you can assume that there is at least one available word for each case.

输出

For each case, print the abbreviation of the word.

样例输入

5

Online Judge

Association for Computer Machinery

Institute of Electrical and Electronics Engineers

The Lord of the Rings

netease

样例输出

OJ

ACM

IEEE

LR

N

import java.util.Scanner;

/**

*

* @author admin

*As we know, we often use a short sequence of characters in place of some words with

*a very long name. For example, ACM is an abbreviation of “Association for Computing

*Machinery”. Now we are using an acronymic method to get the abbreviation. An acronym

*is generated from a long name by capitalizing the first letter of every word in the

*name and concatenating them together. There is an exception: some words are ignored

*when generating the abbreviation. These words( case insensitive) meet the following rules:

*

*1. The common words “and”, “for”, and “the”.

*

*2. The words with length less than 3, such as “a”, “of”, “to”.

*Your job is to get the abbreviation of a given string by using the acronymic method.

*

*输入

*Input starts with an integer T (T <= 100), denoting the number of test cases.

*Each case contains a line with several words seperated by space(s). The length

*of each line is less than 100. And you can assume that there is at least one

*available word for each case.

*输出

*For each case, print the abbreviation of the word.

*实例:

*输入:

*5

*Online Judge

*Association for Computer Machinery

*Institute of Electrical and Electronics Engineers

*The Lord of the Rings

*netease

*输出:

*OJ

*ACM

*IEEE

*LR

*N

*/

public class Abbreviation {

public static void main(String[] args) {

Scanner input=new Scanner(System.in);

int num=Integer.valueOf(input.nextLine());

String[] strArr=new String[num];

for (int i = 0; i < strArr.length; i++) {

strArr[i]=input.nextLine();

}

input.close();

for (int i = 0; i < strArr.length; i++) {

computer(strArr[i]);

}

}

public static void computer(String str)

{

String[] word=str.split(" ");

String tempStr="";

for (int i = 0; i < word.length; i++) {

tempStr+=getWord(word[i]);

}

System.out.println(tempStr);

}

public static String getWord(String str)

{

if(str.length()<3||"and".equals(str)||"for".equals(str)||

"the".equals(str)||"And".equals(str)||"For".equals(str)||"The".equals(str))

{

return"";

}

return str.substring(0, 1).toUpperCase();

}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值