acm-Abbreviation

Abbreviation

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述

As we know, we often use a short sequence of characters in place of some words with a very long name. For example, ACM is an abbreviation of “Association for Computing Machinery”. Now we are using an acronymic method to get the abbreviation. An acronym is generated from a long name by capitalizing the first letter of every word in the name and concatenating them together. There is an exception: some words are ignored when generating the abbreviation. These words( case insensitive) meet the following rules:

 1. The common words “and”, “for”, and “the”.

 2. The words with length less than 3, such as “a”, “of”, “to”. Your job is to get the abbreviation of a given string by using the acronymic method.

输入
Input starts with an integer T (T <= 100), denoting the number of test cases. Each case contains a line with several words seperated by space(s). The length of each line is less than 100. And you can assume that there is at least one available word for each case.
输出
For each case, print the abbreviation of the word.
样例输入
5
Online Judge
Association for Computer Machinery
Institute of Electrical and Electronics Engineers
The Lord of the Rings
netease
样例输出
OJ
ACM
IEEE
LR
N
来源

第11届中山大学程序设计竞赛预选赛(2008年)

我的代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
	int n;
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		char ans[100];
		gets(ans);
		int len=strlen(ans);
		int i,j,k;
		for(i=0;i<len;i++)
		{
			for(j=i+1;j<len;j++)
			{
				if(ans[j]==' ')
					break;	
			}	
			if(j-i>3)
			{
				if(ans[i]>'Z')
					ans[i]-=32;
				printf("%c",ans[i]);	
			}
			else if(j-i==3)
			{
				/*
				char cmp[4];
				cmp[0]=ans[i];
				cmp[1]=ans[i+1];
				cmp[2]=ans[i+2];
				for(k=0;k<3;k++)
					if(cmp[k]<'a')
						cmp[k]+=32;
				cmp[4]='\0';
				*/
				string cmp="";
				for(k=i;k<3+i;k++)
				{
					if(ans[k]<'a')
						ans[k]+=32;
					cmp+=ans[k];	
				}
				if(cmp!="for"&&cmp!="and"&&cmp!="the")//if(!strcmp(cmp,"for")==0&&!strcmp(cmp,"the")==0&&!strcmp(cmp,"and")==0)
				{
					if(cmp[0]>'Z')
						cmp[0]-=32;
					printf("%c",cmp[0]);	
				}
			}
			i=j;
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值