思科同时匹配源和目标地址进行策略路由配置测试

1.测试拓扑:
 
2.基本配置:
R1:
interface FastEthernet0/0
 ip address 12.1.1.1 255.255.255.0
 no shutdown
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
R2:
interface Ethernet0/0
 ip address 12.1.1.2 255.255.255.0
 no shutdown
!
interface Ethernet0/1
 ip address 23.1.1.2 255.255.255.0
 no shutdown
!
interface Ethernet0/2
 ip address 24.1.1.2 255.255.255.0
 no shutdown
R3:
interface FastEthernet0/0
 ip address 23.1.1.3 255.255.255.0
 no shutdown
!
interface FastEthernet0/1
 ip address 50.1.1.3 255.255.255.0
 no shutdown
R4:
interface FastEthernet0/0
 ip address 24.1.1.4 255.255.255.0
 no shutdown
!
interface FastEthernet0/1
 ip address 50.1.1.4 255.255.255.0
 no shutdown
R5:
interface Loopback0
 ip address 5.5.5.5 255.255.255.0
!
interface FastEthernet0/0
 ip address 50.1.1.5 255.255.255.0
 no shutdown
3.静态路由配置:
R1:

ip route 0.0.0.0 0.0.0.0 12.1.1.2
R2:
ip route 0.0.0.0 0.0.0.0 23.1.1.3
ip route 1.1.1.0 255.255.255.0 12.1.1.1
R3:
ip route 5.5.5.0 255.255.255.0 50.1.1.5
ip route 12.1.1.0 255.255.255.0 23.1.1.2
R4:
ip route 1.1.1.0 255.255.255.0 24.1.1.2
ip route 5.5.5.0 255.255.255.0 50.1.1.5
R5:
ip route 0.0.0.0 0.0.0.0 50.1.1.3
ip route 1.1.1.0 255.255.255.0 50.1.1.4
4.R2策略路由配置:
A.配置访问控制列表,匹配流量:

access-list 110 permit ip 1.1.1.0 0.0.0.255 5.5.5.0 0.0.0.255
B.配置route-map,匹配流量后,设置下一跳
route-map net5 permit 10
 match ip address 110
 set ip next-hop 24.1.1.4
!
route-map net5 permit 20
C.在访问控制列表对应流量的进入接口应用route-map
interface Ethernet0/0
 ip policy route-map net5
5.效果测试:
A.R1直接traceroute 5.5.5.5 ,这时的源地址为12.1.1.1
R1#traceroute 5.5.5.5                     

Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 12.1.1.2 36 msec 80 msec 44 msec
  2 23.1.1.3 92 msec 96 msec 60 msec
  3 50.1.1.5 160 msec *  184 msec
R1#
-----可以看到R2根据默认路由配置,将去往5.5.5.5的数据包下一跳扔给了R3。
B.R1指定源地址为1.1.1.1来traceroute 5.5.5.5
R1#traceroute 5.5.5.5 source 1.1.1.1

Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 12.1.1.2 44 msec 100 msec 56 msec
  2 24.1.1.4 68 msec 64 msec 96 msec
  3 50.1.1.5 124 msec *  140 msec
R1#
----可以看到,R2根据策略路由配置,将源地址为1.1.1.1目标地址为5.5.5.5的下一跳扔给了R4。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值