通过R3 设置ip default-network 5.0.0.0作为R1、R2的默认网关访问公网111.111.111.111。

通过show ip eigrp to all查看5.0.0.0两条路由的管理距离及延迟,比较AD/FD,计算va值,并在EIGRP 50中进行设置。

为了模拟非等开销负载均衡,将R2的入向接口带宽及延迟扩大,将R1的入向接口的带宽及延迟缩小。

R1:

R1#show run
Building configuration...

Current configuration : 1123 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
key chain lizhen
 key 1
  key-string cisco
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 bandwidth 1000
 ip address 2.2.2.1 255.255.255.252
 ip authentication mode eigrp 50 md5
 ip authentication key-chain eigrp 50 lizhen
 delay 100
 speed auto
 full-duplex
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 1.1.1.1 255.255.255.252
 ip authentication mode eigrp 50 md5
 ip authentication key-chain eigrp 50 lizhen
 speed auto
 full-duplex
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 50
 variance 10
 network 1.0.0.0
 network 2.0.0.0
 network 3.0.0.0
 auto-summary
!
!
!
ip http server
no ip http secure-server
!
no cdp run
!
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!        
!
end

R2:

R2#show run
Building configuration...

Current configuration : 1112 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
key chain lizhen
 key 1
  key-string cisco
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 2.2.2.2 255.255.255.252
 ip authentication mode eigrp 50 md5
 ip authentication key-chain eigrp 50 lizhen
 speed auto
 full-duplex
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 bandwidth 10000000
 ip address 3.3.3.1 255.255.255.252
 ip authentication mode eigrp 50 md5
 ip authentication key-chain eigrp 50 lizhen
 delay 1
 speed auto
 full-duplex
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 50
 network 1.0.0.0
 network 2.0.0.0
 network 3.0.0.0
 auto-summary
!
!
!
ip http server
no ip http secure-server
!
no cdp run
!
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!        
end

R3:

r3(config)#do show run
Building configuration...

Current configuration : 1122 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
key chain lizhen
 key 1
  key-string cisco
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 3.3.3.2 255.255.255.252
 ip authentication mode eigrp 50 md5
 ip authentication key-chain eigrp 50 lizhen
 speed auto
 full-duplex
!
interface FastEthernet0/1
 ip address 1.1.1.2 255.255.255.252
 ip authentication mode eigrp 50 md5
 ip authentication key-chain eigrp 50 lizhen
 speed auto
 full-duplex
!
interface FastEthernet1/0
 ip address 5.5.5.1 255.255.255.252
 speed auto
 full-duplex
!
router eigrp 50
 network 1.0.0.0
 network 2.0.0.0
 network 3.0.0.0
 network 5.0.0.0
 auto-summary
!
ip default-network 5.0.0.0
ip route 0.0.0.0 0.0.0.0 5.5.5.2
!
!
ip http server
no ip http secure-server
!
no cdp run
!
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R4:

R4#show run
Building configuration...

Current configuration : 743 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 111.111.111.111 255.255.255.0
!
interface FastEthernet0/0
 ip address 5.5.5.2 255.255.255.252
 speed auto
 full-duplex
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 5.5.5.1
!
!
ip http server
no ip http secure-server
!
no cdp run
!
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R4#