fzu 1752 A^B mod C(快速乘+快速幂取模)

题目:http://acm.fzu.edu.cn/problem.php?pid=1752

 Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

 Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

 Output

For each testcase, output an integer, denotes the result of A^B mod C.

 Sample Input

3 2 42 10 1000

 Sample Output

124

分析:
这题时间要求高,所以multi_mod和quick_mod一起使用,同时,不要使用%运算,那样很耗时间。

#include <iostream>
#include<cstdio>
using namespace std;
typedef long long LL;

LL multi_mod(LL a,LL b,LL c){
    LL ans=0;
    while(b){
        if(b&1)ans=ans+a;
        if(ans>=c)ans-=c;
        a=a+a;
        if(a>=c)a-=c;
        b>>=1;
    }
    return ans;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    LL a,b,c;
    while(~scanf("%I64d%I64d%I64d",&a,&b,&c)){
        LL ans=1;
        a=a%c;
        while(b){
            if(b&1)ans=multi_mod(ans,a,c);
            a=multi_mod(a,a,c);
            b>>=1;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值