Cipher

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message. 

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n. 

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

解题思路:

读了半天才看懂题意。题目不难,但要静下心去理解。

题目大意是先给一串数字, 再给一串信息。信息中的每一个字符与给的数字相相应,而相应的数字表示的是该字符应该出如今第几个位置。

依据数字调整好字符的位置后相当于编码一次。然后让你求编码k次后的信息是如何的。

这题必需要找出循环的节点。

字符在编码m次后一定会回到原来的位置,这就是一个循环。记录一个循环中每一个点的位置。编码次数会给的非常大。

假设不用循环来做。是会超时的。

注意:这题每组数据输出之间要空一行。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    int n, k, a[205], m[205][205], huan[205]; //m记录一个循环中每一个节点。huan记录每一个点多久循环一次
    char mes[205], ans[205];
    while(scanf("%d", &n) && n)
    {
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        while(scanf("%d", &k) && k)
        {
            gets(mes);
            for(int i = strlen(mes); i <= n; i++)
                mes[i] = ' ';
            memset(huan, 0, sizeof(huan));
            for(int i = 1; i <= n; i++)
            {
                int temp, j;
                temp = a[i];
                j = 1;
                m[i][j] = temp;
                while(a[temp] != a[i])
                {
                    temp = a[temp];
                    m[i][++j] = temp;  // 记录循环中点的位置
                    huan[i]++;  //仅仅要没有回到原来位置。循环长度加1
                }
                huan[i]++;
            }
            for(int i = 1; i <= n; i++)
            {
                int p, q;
                p = k % huan[i];  // 计算循环后的位置
                if(p)
                    q = m[i][p];
                else
                    q = m[i][huan[i]]; //若能整除说明循环到最后一个
                ans[q - 1] = mes[i];
            }
            ans[n] = '\0';
            printf("%s\n", ans);
        }
        printf("\n");  //每组数据之间要空一行
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
The Java Cipher class provides encryption and decryption functionality in Java. It uses a cryptographic algorithm to perform the encryption and decryption operations. Some common symmetric encryption algorithms include AES, DES, and Blowfish. To use the Cipher class, you first need to create a Cipher object by specifying the encryption algorithm, mode of operation, and padding scheme. Once you have created the Cipher object, you can use it to encrypt or decrypt data. Here's an example of how to use the Cipher class to encrypt and decrypt data using the AES algorithm: ```java import javax.crypto.Cipher; import javax.crypto.KeyGenerator; import javax.crypto.SecretKey; public class CipherExample { public static void main(String[] args) throws Exception { String plainText = "This is some plain text"; // Generate a secret key for the AES algorithm KeyGenerator keyGen = KeyGenerator.getInstance("AES"); keyGen.init(256); SecretKey secretKey = keyGen.generateKey(); // Create a Cipher object using the AES algorithm Cipher cipher = Cipher.getInstance("AES/CBC/PKCS5Padding"); // Encrypt the plain text using the secret key cipher.init(Cipher.ENCRYPT_MODE, secretKey); byte[] encryptedText = cipher.doFinal(plainText.getBytes()); // Decrypt the encrypted text using the same secret key cipher.init(Cipher.DECRYPT_MODE, secretKey); byte[] decryptedText = cipher.doFinal(encryptedText); System.out.println("Plain text: " + plainText); System.out.println("Encrypted text: " + new String(encryptedText)); System.out.println("Decrypted text: " + new String(decryptedText)); } } ``` In this example, we first generate a secret key using the AES algorithm with a key size of 256 bits. We then create a Cipher object using the AES algorithm with CBC mode and PKCS5Padding padding scheme. We use this Cipher object to encrypt the plain text by calling the doFinal method with the Cipher.ENCRYPT_MODE parameter. We then decrypt the encrypted text using the same Cipher object by calling the doFinal method with the Cipher.DECRYPT_MODE parameter. Note that you should always use a secure key size and algorithm when encrypting sensitive data. Also, be sure to store the secret key securely and never share it with unauthorized parties.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值