POJ1003 UVALive2294 HDU1056 ZOJ1045 Hangover【数学计算】

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 125708 Accepted: 61333

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

Source



Regionals 2001 >> North America - Mid-Central USA


问题链接POJ1003 UVALive2294 HDU1056 ZOJ1045 Hangover

题意简述已知c=1/2+1/3+1/4+....1/(n+1),输入m(m是浮点数),求正整数n使得c>=m。

问题分析:从小到大试探n即可。

程序说明:(略)


AC的C语言程序如下:

/* POJ1003 UVALive2294 HDU1056 ZOJ1045 Hangover */

#include <iostream>
#include <cstdio>

using namespace std;

const double one = 1.0;

int main()
{
    double len, sum, d;
    int i;

    while((cin >> len) && len != 0.00) {
        i = 1;

        d = 2.0;
        sum = one / d;
        while(sum < len) {
            d += 1.0;
            sum += (one / d);
            i++;
        }

        cout << i << " card(s)" << endl;
    }

    return 0;
}


转载于:https://www.cnblogs.com/tigerisland/p/7564392.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值