HDU 2131 Probability(水题) by kuangbin

Probability

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2313    Accepted Submission(s): 1146


Problem Description
Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.
 

 

Input
The input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.
 

 

Output
For each test case, print the probability rounded to five digits after the decimal point.
 

 

Sample Input
a apple c Candy a banana
 

 

Sample Output
0.20000 0.20000 0.50000
 

 

Author
KiKi
 

 

Source
 

 

Recommend
威士忌
 
 
#include<stdio.h>
#include<string.h>
char str[210];
int main()
{
char ch1,ch2;
while(scanf("%c %s",&ch1,&str)!=EOF)
{
if(ch1>='a'&&ch1<='z')ch2=ch1-'a'+'A';
else ch2=ch1-'A'+'a';
int len=strlen(str);
int tt=0;
for(int i=0;i<len;i++)
{
if(str[i]==ch1||str[i]==ch2)tt++;
}
printf("%.5lf\n",(double)tt/len);
getchar();
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值