默认情况下帧中继网络是无法运行OSPF协议的,为什么?


 
【原因】:帧中继(fram-relay)网络属于非广播型多路访问,
       而OSPF协议规定路由器之间的Hello包是通过组播来传输
    (组播也属于非广播类型)因此帧中继上默认情况是无法运行OSPF协议的。

 
下面有4种解决方法:
  • 方法一,手工设置ospf网络类型为广播型,在指定fram-relay map时设置为broadcast
    (Fram-relay 广播)
  • 方法二,默认非广播类型,使用neighbor手工指定邻居,并且手工指定DR为中心路由器
    (fram-relay非广播)
  • 方法三,手工设置OSPF网络类型为:点到多点型广播型,在指定fram-relay map时设置为broadcast
    (fram-relay 点对多点广播)
  • 方法四:手工设置OSPF网络类型为:点到多点非广播,使用neighbor手工指定邻居
    (fram-relay 点对多点非广播)

 
再看解决方法之前,先理解以下内容
  1. OSPF中的“neighbor” 可以手动指定邻居路由器的IP地址,使得它不用组播也能和邻居交换路由信息。
  2. 哪些网络需要选举DR,哪些网络不用选举DR
 OSPF网络类型 特征 是否选举DR
 广播型多路访问 以太网、令牌环或FDDI 是
 非广播型多路访问 帧中继、X.25、SMDS 是
 点对点 PPP、HDLC
 否
 点对多点 由管理员配置 否
     3.fram-relay map 中 broadcast 关键词允许路由器通过指定的DLCI号将广播分组分送给所映射的路由器

 
【实验拓扑】:中心-分支帧中继网络拓扑结构

 

 

  • 方法一,手工设置ospf网络类型为广播型,在指定fram-relay map时设置为broadcast
R1:
interface L0
ip address 1.0.0.1 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.1 255.0.0.0
encapsulation frame-relay
ip ospf network broadcast
frame-relay map ip 10.0.0.4 104 broadcast
frame-relay map ip 10.0.0.5 105 broadcast
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
R4:
interface Ethernet0/0
ip address 4.0.0.4 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.4 255.0.0.0
encapsulation frame-relay
ip ospf network broadcast
ip ospf priority 0
frame-relay map ip 10.0.0.1 401 broadcast
frame-relay map ip 10.0.0.5 401
no frame-relay inverse-arp
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0

 
R5:
interface Ethernet0/0
ip address 5.0.0.5 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.5 255.0.0.0
encapsulation frame-relay
ip ospf network broadcast
ip ospf priority 0
frame-relay map ip 10.0.0.1 501 broadcast
frame-relay map ip 10.0.0.4 501
no frame-relay inverse-arp
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
  • 方法二,默认非广播类型,使用neighbor手工指定邻居,并且手工指定DR为中心路由器
R1:
interface Ethernet0/0
ip address 1.0.0.1 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.1 255.0.0.0
encapsulation frame-relay
frame-relay map ip 10.0.0.4 104
frame-relay map ip 10.0.0.5 105
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
neighbor 10.0.0.4
neighbor 10.0.0.5
R4:
interface Ethernet0/0
ip address 4.0.0.4 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.4 255.0.0.0
encapsulation frame-relay
ip ospf priority 0
frame-relay map ip 10.0.0.1 401
frame-relay map ip 10.0.0.5 401
no frame-relay inverse-arp
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
R5:
interface Ethernet0/0
ip address 5.0.0.5 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.5 255.0.0.0
encapsulation frame-relay
ip ospf priority 0
frame-relay map ip 10.0.0.1 501
frame-relay map ip 10.0.0.4 501
no frame-relay inverse-arp
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
  • 方法三,手工设置OSPF网络类型为:点到多点型广播型,在指定fram-relay map时设置为broadcast
R1:
interface Ethernet0/0
ip address 1.0.0.1 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.1 255.0.0.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 10.0.0.4 104 broadcast
frame-relay map ip 10.0.0.5 105 broadcast
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
R4:
interface Ethernet0/0
ip address 4.0.0.4 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.4 255.0.0.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 10.0.0.1 401 broadcast
no frame-relay inverse-arp
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
R5:
interface Ethernet0/0
ip address 5.0.0.5 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.5 255.0.0.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 10.0.0.1 501 broadcast
no frame-relay inverse-arp
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
  • 方法四:手工设置OSPF网络类型为:点到多点非广播,使用neighbor手工指定邻居
R1:
interface Ethernet0/0
ip address 1.0.0.1 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.1 255.0.0.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
frame-relay map ip 10.0.0.4 104
frame-relay map ip 10.0.0.5 105
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
neighbor 10.0.0.5
neighbor 10.0.0.4
R4:
interface Ethernet0/0
ip address 4.0.0.4 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.4 255.0.0.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
frame-relay map ip 10.0.0.1 401
no frame-relay inverse-arp
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
R5:
interface Ethernet0/0
ip address 5.0.0.5 255.0.0.0
!
interface Serial0/0
ip address 10.0.0.5 255.0.0.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
frame-relay map ip 10.0.0.1 501
no frame-relay inverse-arp
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0