HDU 1395 2^x mod n = 1

2^x mod n = 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17023    Accepted Submission(s): 5313


Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
 

 

Input
One positive integer on each line, the value of n.
 

 

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.
 

 

Sample Input
2 5
 

 

Sample Output
2^? mod 2 = 1 2^4 mod 5 = 1
 

 

Author
MA, Xiao
 

 

Source
 

 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   2462  2421  2521  1695  2466 
直接暴力,偶数和1不可能,其余奇数都可以
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<cmath>
using namespace std;
#define maxn 1010
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n%2==0||n==1)
        {
            printf("2^? mod %d = 1\n",n);
            continue;
        }
        int m = 1,num;
        for(int i=1; ;i++)//因为绝对可以,所以这里写成死循环,暴力
        {
            m = m * 2;
            m = m%n;//注意这里要取余!!!
            if(m%n==1)
            {
                num = i;
                break;
            }

        }
        printf("2^%d mod %d = 1\n",num,n);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/l609929321/p/6606391.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值