Conturbatio

Conturbatio

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 234    Accepted Submission(s): 110


Problem Description
There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place.

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook?
 

 

Input
The first line of the input is a integer  T, meaning that there are T test cases.

Every test cases begin with four integers n,m,K,Q.
K is the number of Rook, Q is the number of queries.

Then K lines follow, each contain two integers x,y describing the coordinate of Rook.

Then Q lines follow, each contain four integers x1,y1,x2,y2 describing the left-down and right-up coordinates of query.

1n,m,K,Q100,000.

1xn,1ym.

1x1x2n,1y1y2m.
 

 

Output
For every query output "Yes" or "No" as mentioned above.
 

 

Sample Input
2
2 2 1 2
1 1
1 1 1 2
2 1 2 2
 
2 2 2 1
1 1
1 2
2 1 2 2
 

 

Sample Output
Yes
No
Yes
 
Hint
Huge input, scanf recommended.
 

 题意:给你象棋中所有车的位置,每次询问矩形给你左上角和右上角的点,问这个矩形中的点是否可以被车吃完。

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

#define maxn 110008
int x[maxn], y[maxn];

int main()
{
    int t, n, m, k, q, a, b, x1, x2, y1, y2;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d%d%d", &n, &m, &k, &q);
        memset(x, 0, sizeof(x));
        memset(y, 0, sizeof(y));
        for(int i = 0; i < k; i++)
        {
            scanf("%d%d", &a, &b);
            x[a] = 1;
            y[b] = 1;
        }

        for(int i = 2; i <= n; i++)
            x[i] += x[i-1];
        for(int i = 2; i <= m; i++)
            y[i] += y[i-1];

        for(int w = 0; w < q; w++)
        {
            int i, j;
            scanf("%d%d%d%d", &x1, &y1, &x2, &y2);

            if(x[x2]-x[x1-1] == x2-x1+1 || y[y2]-y[y1-1] == y2-y1+1)  // 每次查询看是否矩形所在的所有行或所有列全部被车吃掉
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/Tinamei/p/4841862.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值