POJ 2167 Irrelevant Elements 质因数分解



Irrelevant Elements
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 2231 Accepted: 550
Case Time Limit: 2000MS

Description

Young cryptoanalyst Georgie is investigating different schemes of generating random integer numbers ranging from 0 to m - 1. He thinks that standard random number generators are not good enough, so he has invented his own scheme that is intended to bring more randomness into the generated numbers. 
First, Georgie chooses n and generates n random integer numbers ranging from 0 to m - 1. Let the numbers generated be a1, a2, . . . , an. After that Georgie calculates the sums of all pairs of adjacent numbers, and replaces the initial array with the array of sums, thus getting n - 1 numbers: a1 + a2, a2 + a3, . . . , a n-1 + an. Then he applies the same procedure to the new array, getting n - 2 numbers. The procedure is repeated until only one number is left. This number is then taken modulo m. That gives the result of the generating procedure. 
Georgie has proudly presented this scheme to his computer science teacher, but was pointed out that the scheme has many drawbacks. One important drawback is the fact that the result of the procedure sometimes does not even depend on some of the initially generated numbers. For example, if n = 3 and m = 2, then the result does not depend on a2. 
Now Georgie wants to investigate this phenomenon. He calls the i-th element of the initial array irrelevant if the result of the generating procedure does not depend on ai. He considers various n and m and wonders which elements are irrelevant for these parameters. Help him to find it out.

Input

Input contains n and m (1 <= n <= 100 000, 2 <= m <= 10 9).

Output

On the first line of the output print the number of irrelevant elements of the initial array for given n and m. On the second line print all such i that i-th element is irrelevant. Numbers on the second line must be printed in the ascending order and must be separated by spaces.

Sample Input

3 2

Sample Output

1
2

Source

[Submit]   [Go Back]   [Status]   [Discuss]



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

const int maxn=100100;

int n,m;
int pm[maxn],pr[maxn],pc[maxn],pn;
vector<int> ans;

void f(int x,int d)
{
    for(int i=0;i<pn;i++)
        while(x%pm[i]==0)
        {
            pc[i]+=d;
            x/=pm[i];
        }
}

bool check()
{
    for(int i=0;i<pn;i++)
    {
        if(pc[i]<pr[i]) return false;
    }
    return true;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans.clear(); pn=0;

        /**********/
        for(int i=2;i*i<=m;i++)
        {
            if(m%i==0)
            {
                pm[pn]=i;
                while(m%i==0)
                {
                    pr[pn]++;
                    m/=i;
                }
                pn++;
            }
        }
        if(m!=1)
        {
            pm[pn]=m;
            pr[pn++]=1;
        }
        /**********/
        n--;
        for(int i=1;i<=n;i++)
        {
            f(n-i+1,1);
            f(i,-1);
            if(check())
            {
                ans.push_back(i+1);
            }
        }

        printf("%d\n",ans.size());
        sort(ans.begin(),ans.end());
        for(int i=0,sz=ans.size();i<sz;i++)
        {
            printf("%d ",ans[i]);
        }
        putchar(10);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值