2017 Multi-University Training Contest - Team 4

日常绝望系列

Questionnaire

 HDU - 6075 

In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training. 


 
Picture from Wikimedia Commons 


Obviously many people don't want more training, so the clever leader didn't write down their words such as ''Yes'' or ''No''. Instead, he let everyone choose a positive integer  aiai to represent his opinion. When finished, the leader will choose a pair of positive interges m(m>1)m(m>1) and k(0k<m)k(0≤k<m), and regard those people whose number is exactly kk modulo mm as ''Yes'', while others as ''No''. If the number of ''Yes'' is not less than ''No'', the leader can have chance to offer more training. 

Please help the team leader to find such pair of mm and kk.

InputThe first line of the input contains an integer T(1T15)T(1≤T≤15), denoting the number of test cases. 

In each test case, there is an integer n(3n100000)n(3≤n≤100000) in the first line, denoting the number of people in the ACM/ICPC team. 

In the next line, there are nn distinct integers a1,a2,...,an(1ai109)a1,a2,...,an(1≤ai≤109), denoting the number that each person chosen.
OutputFor each test case, print a single line containing two integers m and k, if there are multiple solutions, print any of them.

Sample Input

1

6

23 3 18 8 13 9

Sample Output

5 3

这道题最水,看到特判又是膜的,那么m肯定是2啊,这样的话k只有两种结果,模拟下,so easy

#include<bits/stdc++.h>
using namespace std;
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
    int n;
    scanf("%d",&n);
    int one=0;
    for(int i=0;i<n;i++){
        int x;
        scanf("%d",&x);
        if(x&1)one++;
    }
    int f=0;
    if(one>=(n+1)/2)f=1;
    printf("2 %d\n",f);
    }
return 0;}

Time To Get Up

 HDU - 6077 

Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  55alarms, and it's just the first one, he can continue sleeping for a while. 

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times. 



Your job is to help Little Q read the time shown on his clock.

InputThe first line of the input contains an integer T(1T1440)T(1≤T≤1440), denoting the number of test cases. 

In each test case, there is an 7×217×21 ASCII image of the clock screen. 

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
OutputFor each test case, print a single line containing a string tt in the format of HH:MMHH:MM, where t(00:00t23:59)t(00:00≤t≤23:59), denoting the time shown on the clock.Sample Input

1
.XX...XX.....XX...XX.
X..X....X......X.X..X
X..X....X.X....X.X..X
......XX.....XX...XX.
X..X.X....X....X.X..X
X..X.X.........X.X..X
.XX...XX.....XX...XX.

Sample Output

02:38

模拟啦,暴力一下就行,分情况讨论7个位置有没有,表示我在这方面的能力有些弱哎

#include<bits/stdc++.h>
using namespace std;
char s[10][30];
int dfs(int x,int y){
    if(s[x][y+1]=='X'){
    if(s[x+1][y+3]!='X'){
        if(s[x+5][y]=='X')
            return 6;
        else
            return 5;
    }
    else{
        if(s[x+3][y+1]!='X'){
            if(s[x+5][y]=='X')
            return 0;
            else return 7;
        }
        else if(s[x+5][y+3]!='X')
            return 2;
        else if(s[x+5][y]=='X')
            return 8;
        else if(s[x+1][y]=='X')
            return 9;
        else return 3;

    }
}
else {
    if(s[x+1][y]=='X')
        return 4;
    else return 1;
}
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        getchar();
    for(int i=0;i<7;i++)
        scanf("%s",s[i]);
    printf("%d%d:%d%d\n",dfs(0,0),dfs(0,5),dfs(0,12),dfs(0,17));
    }
return 0;}

 

转载于:https://www.cnblogs.com/BobHuang/p/7283187.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值