可以在R3 上的端口 f 1/0 上加上几句

(config-router)# ip summary-address eigrp 100 192.168.0.0 255.255.0.0

减少 R4 中的路由条目

因为路由器的路由ID为了好看,所以取了A类的 1.1.1.1~6.6.6.6 导致汇总不好汇总. 失败.呵呵.

r1>en
Password:
r1#show run
Building configuration...

Current configuration : 871 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1   //主机名
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$nFbz$rMMnSa5j4as5.FCiB0BlE0  //加密口令
!
no aaa new-model
ip subnet-zero    // 可使用子网0
!
!
no ip domain lookup     // no 掉 name-server
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0        //本地回环0           
 ip address 192.168.50.1 255.255.255.255
!
interface Loopback1        //本地回环1 (虚拟出来测试用的)
 ip address 192.168.30.1 255.255.255.248
!
interface FastEthernet0/0
 ip address 192.168.30.9 255.255.255.248
 duplex half

interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
router ospf 1         // ospf 进程 1
 log-adjacency-changes
 area 1 stub          // stub 区域, 在ABR 设置 no-summary , 变成 totally stub
 network 192.168.30.0 0.0.0.255 area 1   // 宣告
!
ip classless            // 无类路由查询
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
line con 0
 stopbits 1
line aux 0
line vty 0 4         // 开启 telnet
 password 123        // telnet 密码
 login
!
!
end

r1#show ip ospf database database-summary

            OSPF Router with ID (192.168.50.1) (Process ID 1)

Area 1 database summary                  
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       1        0        0      
  Summary Net   1        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      4        0        0      

Process 1 database summary               
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       1        0        0      
  Summary Net   1        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Type-5 Ext    0        0        0      
  Opaque AS     0        0        0      
  Total         4        0        0      
r1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.30.10 to network 0.0.0.0

     192.168.30.0/29 is subnetted, 2 subnets
C       192.168.30.0 is directly connected, Loopback1
C       192.168.30.8 is directly connected, FastEthernet0/0
       192.168.50.0/32 is subnetted, 2 subnets
O       192.168.50.2 [110/2] via 192.168.30.10, 00:22:37, FastEthernet0/0 
C       192.168.50.1 is directly connected, Loopback0
O*IA 0.0.0.0/0 [110/2] via 192.168.30.10, 00:22:05, FastEthernet0/0   // 3 类缺省 , 优化 r1 的路由表

r1#192.168.30.10                   // telnet 到 r2
Trying 192.168.30.10 ... Open


User Access Verification

Password:
r2>en
Password:
r2#show run
Building configuration...

Current configuration : 875 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2       // 主机名 r2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Hfq3$r7mcZQStWzg7BVqq.26pO0   // 加密口令
!
no aaa new-model
ip subnet-zero  //使用子网0
!
!
no ip domain lookup  // 关闭域名解析
!
ip cef
!

!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.50.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.30.10 255.255.255.248
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.20.1 255.255.255.252
 duplex half
!
router ospf 1
 log-adjacency-changes
 area 1 stub no-summary                   // ABR , stub 区域所有router必须都配置为stub, 在ABR 配置 no-summary,使区域称为 totally stub area
 network 192.168.20.0 0.0.0.255 area 0    // 宣告
 network 192.168.30.0 0.0.0.255 area 1    // 宣告
 network 192.168.50.2 0.0.0.0 area 1      // 宣告
!
ip classless      // 无类路由查询
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
line con 0
 stopbits 1
line aux 0
line vty 0 4     // 开启 telnet
 password 123    // telnet 密码
 login
!
!
end

r2#show ip ospf database database-summary

            OSPF Router with ID (192.168.50.2) (Process ID 1)

Area 0 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0       
  Network       1        0        0      
  Summary Net   6        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      9        0        0      

Area 1 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       1        0        0      
  Summary Net   1        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      4        0        0      

Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router        4        0        0      
  Network       2        0        0     
  Summary Net   7        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Type-5 Ext    5        0        0      
  Opaque AS     0        0        0      
  Total         18       0        0      
r2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.30.0/24 is variably subnetted, 2 subnets, 2 masks
O       192.168.30.1/32 [110/2] via 192.168.30.9, 00:22:31, FastEthernet0/0
C       192.168.30.8/29 is directly connected, FastEthernet0/0
     192.168.10.0/27 is subnetted, 1 subnets
O IA    192.168.10.0 [110/2] via 192.168.20.2, 00:17:54, FastEthernet1/0
     172.19.0.0/25 is subnetted, 1 subnets
O E2    172.19.35.0 [110/10] via 192.168.20.2, 00:17:49, FastEthernet1/0         
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, FastEthernet1/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O E2    10.2.2.0/24 [110/10] via 192.168.20.2, 00:17:49, FastEthernet1/0         
O E2    10.1.1.0/29 [110/10] via 192.168.20.2, 00:17:49, FastEthernet1/0         
     192.168.50.0/24 is variably subnetted, 6 subnets, 2 masks
C       192.168.50.2/32 is directly connected, Loopback0
O       192.168.50.3/32 [110/2] via 192.168.20.2, 00:22:32, FastEthernet1/0
O E2    192.168.50.0/24 [110/10] via 192.168.20.2, 00:02:00, FastEthernet1/0
O       192.168.50.1/32 [110/2] via 192.168.30.9, 00:22:32, FastEthernet0/0
O E2    192.168.50.4/32 [110/10] via 192.168.20.2, 00:17:50, FastEthernet1/0     
O IA    192.168.50.5/32 [110/3] via 192.168.20.2, 00:17:50, FastEthernet1/0

r2#192.168.20.2                    // telnet 到 r 3
Trying 192.168.20.2 ... Open


User Access Verification

Password:
r3>en
Password:
r3#show run
Building configuration...

Current configuration : 1143 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$fLpG$ugh.ML9BEMnh.jlccxY9S1
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.50.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.20.2 255.255.255.252
 duplex half
!
interface FastEthernet1/0
 ip address 10.1.1.5 255.255.255.248
 duplex half
!
interface FastEthernet2/0
 ip address 192.168.10.1 255.255.255.224
 duplex half
!
router eigrp 100                                    // 进程号必须相同
 redistribute ospf 1 metric 100000 100 255 5 1500   // 把 ospf 注入 ergip  带宽 时延 可靠性 负载 MTU
 network 10.0.0.0           // 宣告
 auto-summary
!
router ospf 1
 log-adjacency-changes
 area 2 nssa no-redistribution default-information-originate no-summary   // 这里其实no-summary 是不用再default-information-originate 的,但是变相看出r 5的缺
                                                                             省路由变成了 3类, 7类其实只有再没有 no-summary 才启效, 否则屏蔽在 3类下.
 redistribute eigrp 100 metric 10 subnets                                 // 把 eigrp 注入 ospf                         
 network 192.168.10.0 0.0.0.255 area 2                                    // 宣告
 network 192.168.20.0 0.0.0.255 area 0                                    // 宣告
 network 192.168.50.3 0.0.0.0 area 0                                      // 宣告
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
 password 123
 login
!
!
end

r3#show ip ospf database database-summary

            OSPF Router with ID (192.168.50.3) (Process ID 1)

Area 0 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       1        0        0      
  Summary Net   6        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      9        0        0      

Area 2 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       1        0        0      
  Summary Net   1        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    3        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      7        0        0      

Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router        4        0        0      
  Network       2        0        0      
  Summary Net   7        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    3        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Type-5 Ext    5        0        0      
  Opaque AS     0        0        0      
  Total         21       0        0      
r3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.30.0/24 is variably subnetted, 2 subnets, 2 masks
O IA    192.168.30.1/32 [110/3] via 192.168.20.1, 00:14:06, FastEthernet0/0
O IA    192.168.30.8/29 [110/2] via 192.168.20.1, 00:14:06, FastEthernet0/0
     192.168.10.0/27 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, FastEthernet2/0
     172.19.0.0/25 is subnetted, 1 subnets
O N2    172.19.35.0 [110/10] via 192.168.10.2, 00:14:06, FastEthernet2/0  // LSA 7 类 从 RIP 泛洪在 nssa区域获得
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       10.2.2.0/24 [90/156160] via 10.1.1.6, 00:51:36, FastEthernet1/0
C       10.1.1.0/29 is directly connected, FastEthernet1/0
     192.168.50.0/24 is variably subnetted, 6 subnets, 2 masks
O IA    192.168.50.2/32 [110/2] via 192.168.20.1, 00:14:07, FastEthernet0/0
C       192.168.50.3/32 is directly connected, Loopback0
O N2    192.168.50.0/24 [110/10] via 192.168.10.2, 00:02:20, FastEthernet2/0  // LSA 7 类 从 RIP 泛洪在 nssa区域获得
O IA    192.168.50.1/32 [110/3] via 192.168.20.1, 00:14:07, FastEthernet0/0
D       192.168.50.4/32 [90/156160] via 10.1.1.6, 00:51:37, FastEthernet1/0   // eigrp 注入获得
O       192.168.50.5/32 [110/2] via 192.168.10.2, 00:14:07, FastEthernet2/0


r3#10.1.1.6                          //telnet 到 r 4
Trying 10.1.1.6 ... Open


User Access Verification

Password:
r4>en
Password:
r4#show run
Building configuration...

Current configuration : 861 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$KN2Y$79ZsH8DmO6F8LDMoKYk5p.
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.50.4 255.255.255.255
!
interface Loopback1
 ip address 10.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.1.6 255.255.255.252
 duplex half
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
router eigrp 100      //启动 eigrp 进程 ,进程号于 r 3 相同
 network 10.0.0.0      // 宣告
 network 192.168.50.0  // 宣告
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 area 2 nssa
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
 password 123
 login
!
!
end

r4#show ip ospf database DAtabase-summary

            OSPF Router with ID (192.168.50.4) (Process ID 1)

Area 2 database summary
  LSA Type      Count    Delete   Maxage
  Router        0        0        0      
  Network       0        0        0      
  Summary Net   0        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      0        0        0      

Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router        0        0        0      
  Network       0        0        0      
  Summary Net   0        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Type-5 Ext    0        0        0      
  Opaque AS     0        0        0      
  Total         0        0        0      
r4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.30.0/24 is variably subnetted, 2 subnets, 2 masks
D EX    192.168.30.1/32 [170/53760] via 10.1.1.5, 00:28:28, FastEthernet0/0    // eigrp 从 ospf 注入的
D EX    192.168.30.8/29 [170/53760] via 10.1.1.5, 00:28:33, FastEthernet0/0
     192.168.10.0/27 is subnetted, 1 subnets
D EX    192.168.10.0 [170/53760] via 10.1.1.5, 00:50:41, FastEthernet0/0
     172.19.0.0/25 is subnetted, 1 subnets
D EX    172.19.35.0 [170/53760] via 10.1.1.5, 00:19:21, FastEthernet0/0
     192.168.20.0/30 is subnetted, 1 subnets
D EX    192.168.20.0 [170/53760] via 10.1.1.5, 00:50:41, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.2.2.0/24 is directly connected, Loopback1
C       10.1.1.4/30 is directly connected, FastEthernet0/0
     192.168.50.0/32 is subnetted, 5 subnets
D EX    192.168.50.2 [170/53760] via 10.1.1.5, 00:50:41, FastEthernet0/0
D EX    192.168.50.3 [170/53760] via 10.1.1.5, 00:49:42, FastEthernet0/0
D EX    192.168.50.1 [170/53760] via 10.1.1.5, 00:28:29, FastEthernet0/0
C       192.168.50.4 is directly connected, Loopback0
D EX    192.168.50.5 [170/53760] via 10.1.1.5, 00:19:22, FastEthernet0/0

r4#192.168.10.2                     // telnet 到 r 5
Trying 192.168.10.2 ... Open


User Access Verification

Password:
r5>en
Password:
r5#show run
Building configuration...

Current configuration : 923 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r5
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$pXvU$0p.wge6o4efg7WtWElv/e1
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.50.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.10.2 255.255.255.224
 duplex half
!
interface FastEthernet1/0
 ip address 172.19.35.15 255.255.255.128
 duplex half
!
router ospf 1
 log-adjacency-changes
 area 2 nssa                            // nssa 区域内的路由器必须统一设置为nssa 区域
 redistribute rip metric 10 subnets     // 注入 rip 信息
 network 192.168.10.0 0.0.0.31 area 2   // 宣告
 network 192.168.50.5 0.0.0.0 area 2    // 宣告
!
router rip
 redistribute ospf 1 metric 10          // 给rip 注入 ospf 信息
 network 172.19.0.0                     // 宣告
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
 password 123
 login
!
!
end

r5#show ip ospf database database-summary

            OSPF Router with ID (192.168.50.5) (Process ID 1)

Area 2 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       1        0        0      
  Summary Net   1        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    2        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      6        0        0      

Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       1        0        0      
  Summary Net   1        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    2        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Type-5 Ext    0        0        0      
  Opaque AS     0        0        0      
  Total         6        0        0      

r5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/27 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, FastEthernet0/0
     172.19.0.0/25 is subnetted, 1 subnets
C       172.19.35.0 is directly connected, FastEthernet1/0
     192.168.50.0/32 is subnetted, 1 subnets
C       192.168.50.5 is directly connected, Loopback0
O*IA 0.0.0.0/0 [110/2] via 192.168.10.1, 00:16:05, FastEthernet0/0    // 这里体现了 r3 作为 ASBR/ABR ,输入 no-summary no-redistribution 的功效

r5#172.19.35.1
Trying 172.19.35.1 ... Open


User Access Verification

Password:
r6>en
Password:
r6#show run
Building configuration...

Current configuration : 732 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r6
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$MF75$hdDRi34xb6xvhNW4nvbn6.
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.50.6 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.19.35.1 255.255.255.128
 duplex half
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
router rip              //  开启 rip 进程
 network 172.19.0.0     //  宣告
 network 192.168.50.0   //  宣告
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
 password 123
 login
!
!
end


r6#show ip ospf database  database-summary

r6#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.19.35.15 to network 0.0.0.0

R    192.168.10.0/24 [120/10] via 172.19.35.15, 00:00:04, FastEthernet0/0
     172.19.0.0/25 is subnetted, 1 subnets
C       172.19.35.0 is directly connected, FastEthernet0/0
C    192.168.50.0/24 is directly connected, Loopback0
R*   0.0.0.0/0 [120/10] via 172.19.35.15, 00:00:04, FastEthernet0/0          // r 5 的默认在注入时也就注入了rip

r6#ping 10.2.2.2                //测试到 eigrp

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 260/268/296 ms
r6#ping 192.168.10.1            // 测试到远端

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 144/177/200 ms