(水题)987654321 problem -- SGU 107

链接:

http://vj.acmclub.cn/contest/view.action?cid=168#problem/G

 

时限:250MS     内存:4096KB     64位IO格式:%I64d & %I64u
提交  状态  练习  SGU 107

问题描述

 

For given number N you must output amount of N-digit numbers, such, that last digits of their square is equal to 987654321.

 

Input

Input contains integer number N (1<=N<=106)

 

Output

Write answer to the output.

 

Sample Input

8

Sample Output

0

不看输入,没选语言,错了两次,醉了

 

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<queue>

using namespace std;

const long long MOD = 1000000000;

 int main()
 {
     int n;
     while(scanf("%d", &n)!=EOF)
     {

         /*

         int ans=0;
         for(long long i=1; i<=n; i++)
         {
             if((i*i)%MOD==987654321)
                ans ++ ;
         }
         */

         if(n<=8)
            printf("0\n");
         else if(n==9)
            printf("8\n");
        else
        {
            printf("72");

            for(int i=11; i<=n; i++)
                printf("0");
            printf("\n");
        }

     }
    return 0;
 }

 

转载于:https://www.cnblogs.com/YY56/p/4814941.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值